summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/gparted')
-rw-r--r--sys-block/gparted/ChangeLog6
-rw-r--r--sys-block/gparted/files/gparted-0.3.1-llabs.patch72
-rw-r--r--sys-block/gparted/gparted-0.3.1.ebuild9
3 files changed, 84 insertions, 3 deletions
diff --git a/sys-block/gparted/ChangeLog b/sys-block/gparted/ChangeLog
index a3acd23905fb..99d595a372cc 100644
--- a/sys-block/gparted/ChangeLog
+++ b/sys-block/gparted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/gparted
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/gparted/ChangeLog,v 1.29 2006/09/15 20:10:11 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/gparted/ChangeLog,v 1.30 2006/09/26 13:28:06 blubb Exp $
+
+ 26 Sep 2006; Simon Stelling <blubb@gentoo.org>
+ +files/gparted-0.3.1-llabs.patch, gparted-0.3.1.ebuild:
+ fixing the llabs issue for 0.3.1; bug 149122; thanks Ed Catmur for the patch
*gparted-0.3.1 (15 Sep 2006)
diff --git a/sys-block/gparted/files/gparted-0.3.1-llabs.patch b/sys-block/gparted/files/gparted-0.3.1-llabs.patch
new file mode 100644
index 000000000000..fddbc7dfe0e4
--- /dev/null
+++ b/sys-block/gparted/files/gparted-0.3.1-llabs.patch
@@ -0,0 +1,72 @@
+--- src/GParted_Core.cc 2006/09/25 21:49:32 1.1
++++ src/GParted_Core.cc 2006/09/25 22:03:31
+@@ -1604,7 +1604,7 @@ bool GParted_Core::copy_filesystem( cons
+
+ while ( succes &&
+ timer .elapsed() <= smallest_time &&
+- std::abs( done ) + N <= length &&
++ llabs( done ) + N <= length &&
+ optimal_blocksize * 2 < N )
+ {
+ if ( done != 0 )
+@@ -1648,7 +1648,7 @@ bool GParted_Core::copy_filesystem( cons
+ dst_device,
+ src_start + ( dst_start > src_start ? 0 : done ),
+ dst_start + ( dst_start > src_start ? 0 : done ),
+- length - std::abs( done ),
++ length - llabs( done ),
+ optimal_blocksize,
+ operationdetail,
+ readonly,
+@@ -1822,7 +1822,7 @@ bool GParted_Core::copy_blocks( const Gl
+ if ( lp_device_src && lp_device_dst && ped_device_open( lp_device_src ) && ped_device_open( lp_device_dst ) )
+ {
+ Glib::ustring error_message ;
+- buf = static_cast<char *>( malloc( std::abs( blocksize ) * 512 ) ) ;
++ buf = static_cast<char *>( malloc( llabs( blocksize ) * 512 ) ) ;
+ if ( buf )
+ {
+ ped_device_sync( lp_device_dst ) ;
+@@ -1843,7 +1843,7 @@ bool GParted_Core::copy_blocks( const Gl
+ operationdetail .get_last_child() .add_child( OperationDetail( "", STATUS_NONE ) ) ;
+
+ Glib::Timer timer_progress_timeout, timer_total ;
+- while( succes && std::abs( done ) < length )
++ while( succes && llabs( done ) < length )
+ {
+ succes = copy_block( lp_device_src,
+ lp_device_dst,
+@@ -1858,7 +1858,7 @@ bool GParted_Core::copy_blocks( const Gl
+ if ( timer_progress_timeout .elapsed() >= 0.5 )
+ {
+ set_progress_info( length,
+- std::abs( done + blocksize ),
++ llabs( done + blocksize ),
+ timer_total,
+ operationdetail .get_last_child() .get_last_child(),
+ readonly ) ;
+@@ -1877,13 +1877,13 @@ bool GParted_Core::copy_blocks( const Gl
+
+ //final description
+ operationdetail .get_last_child() .get_last_child() .set_description(
+- String::ucompose( readonly ? _("%1 of %2 read") : _("%1 of %2 copied"), std::abs( done ), length ), FONT_ITALIC ) ;
++ String::ucompose( readonly ? _("%1 of %2 read") : _("%1 of %2 copied"), llabs( done ), length ), FONT_ITALIC ) ;
+
+ if ( ! succes && ! error_message .empty() )
+ operationdetail .get_last_child() .add_child(
+ OperationDetail( error_message, STATUS_NONE, FONT_ITALIC ) ) ;
+
+- total_done += std::abs( done ) ;
++ total_done += llabs( done ) ;
+
+ //close and destroy the devices..
+ ped_device_close( lp_device_src ) ;
+@@ -1912,7 +1912,7 @@ bool GParted_Core::copy_block( PedDevice
+
+ if ( blocksize < 0 )
+ {
+- blocksize = std::abs( blocksize ) ;
++ blocksize = llabs( blocksize ) ;
+ offset_src -= ( blocksize -1 ) ;
+ offset_dst -= ( blocksize -1 ) ;
+ }
diff --git a/sys-block/gparted/gparted-0.3.1.ebuild b/sys-block/gparted/gparted-0.3.1.ebuild
index cbe90a5e0c00..048ff2a89f5e 100644
--- a/sys-block/gparted/gparted-0.3.1.ebuild
+++ b/sys-block/gparted/gparted-0.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/gparted/gparted-0.3.1.ebuild,v 1.1 2006/09/15 20:10:11 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/gparted/gparted-0.3.1.ebuild,v 1.2 2006/09/26 13:28:06 blubb Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="Gnome Partition Editor"
HOMEPAGE="http://gparted.sourceforge.net/"
@@ -27,3 +27,8 @@ RDEPEND=">=sys-apps/parted-1.7.1
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12
>=dev-util/intltool-0.29"
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/${P}-llabs.patch
+}