summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild')
-rw-r--r--sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild
new file mode 100644
index 000000000000..062262779e34
--- /dev/null
+++ b/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-pkla-compat/polkit-pkla-compat-0.1.ebuild,v 1.1 2013/05/11 13:42:15 ssuominen Exp $
+
+EAPI=5
+
+DESCRIPTION="Rules for polkit to add compatibility with pklocalauthority"
+HOMEPAGE="http://fedorahosted.org/polkit-pkla-compat/"
+SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.30
+ >=sys-auth/polkit-0.110"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+src_install() {
+ default
+ fowners -R root:polkitd /etc/polkit-1/localauthority
+}
+
+pkg_postinst() {
+ chown -R root:polkitd "${EROOT}"/etc/polkit-1/localauthority
+}