summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_mount/pam_mount-2.11.ebuild')
-rw-r--r--sys-auth/pam_mount/pam_mount-2.11.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-auth/pam_mount/pam_mount-2.11.ebuild b/sys-auth/pam_mount/pam_mount-2.11.ebuild
index dd1c76d589d4..4b28a902b28d 100644
--- a/sys-auth/pam_mount/pam_mount-2.11.ebuild
+++ b/sys-auth/pam_mount/pam_mount-2.11.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.11.ebuild,v 1.1 2011/08/14 18:31:29 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.11.ebuild,v 1.2 2011/08/18 00:03:00 mattst88 Exp $
EAPI=4
-inherit multilib
+inherit eutils multilib
DESCRIPTION="A PAM module that can mount volumes for a user session"
HOMEPAGE="http://pam-mount.sourceforge.net"
@@ -27,6 +27,10 @@ DEPEND="${COMMON_DEPEND}
app-arch/xz-utils"
RDEPEND="${COMMON_DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-build-without-cryptsetup.patch
+}
+
src_configure() {
econf --with-slibdir="/$(get_libdir)" \
$(use_with crypt cryptsetup) \