summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild')
-rw-r--r--sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild b/sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild
index f394dbce289a..81c76b3525be 100644
--- a/sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild
+++ b/sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild,v 1.10 2012/04/26 17:54:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mktemp/pam_mktemp-1.1.1.ebuild,v 1.11 2012/08/21 02:32:02 flameeyes Exp $
EAPI="4"
-inherit toolchain-funcs pam
+inherit toolchain-funcs pam eutils
DESCRIPTION="Create per-user private temporary directories during login"
HOMEPAGE="http://www.openwall.com/pam/"
@@ -15,9 +15,14 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="selinux +prevent-removal"
-DEPEND="virtual/pam
+RDEPEND="virtual/pam
selinux? ( sys-libs/libselinux )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ prevent-removal? ( sys-kernel/linux-headers )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-e2fsprogs-libs.patch
+}
src_compile() {
emake \