summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/libnss-mysql')
-rw-r--r--sys-auth/libnss-mysql/ChangeLog11
-rw-r--r--sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r3.ebuild (renamed from sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild)26
2 files changed, 24 insertions, 13 deletions
diff --git a/sys-auth/libnss-mysql/ChangeLog b/sys-auth/libnss-mysql/ChangeLog
index ad2a4a22fbde..4ac72cbcba58 100644
--- a/sys-auth/libnss-mysql/ChangeLog
+++ b/sys-auth/libnss-mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/libnss-mysql
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/ChangeLog,v 1.23 2012/01/09 19:45:13 ranger Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/ChangeLog,v 1.24 2014/07/31 02:57:55 grknight Exp $
+
+*libnss-mysql-1.5_p20060915-r3 (31 Jul 2014)
+
+ 31 Jul 2014; Brian Evans <grknight@gentoo.org>
+ +libnss-mysql-1.5_p20060915-r3.ebuild, -libnss-mysql-1.5_p20060915-r1.ebuild:
+ Revbump for EAPI5. Drop oldest revision
09 Jan 2012; Brent Baude <ranger@gentoo.org>
libnss-mysql-1.5_p20060915-r2.ebuild:
@@ -164,4 +170,3 @@
03 Jun 2003; Max Kalika <max@gentoo.org> LSIT_libnss-mysql-0.8.ebuild:
Initial version.
-
diff --git a/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild b/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r3.ebuild
index 9a391d848804..3ef92c166c52 100644
--- a/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild
+++ b/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r3.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r1.ebuild,v 1.4 2011/05/28 12:05:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r3.ebuild,v 1.1 2014/07/31 02:57:55 grknight Exp $
-EAPI=2
+EAPI=5
inherit eutils multilib autotools
-KEYWORDS="amd64 ppc ~sparc x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
DESCRIPTION="NSS MySQL Library."
HOMEPAGE="http://libnss-mysql.sourceforge.net/"
@@ -16,28 +16,34 @@ SLOT="0"
IUSE="debug"
DEPEND="virtual/mysql"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
+DOCS=( AUTHORS DEBUGGING FAQ INSTALL NEWS README THANKS
+ TODO UPGRADING ChangeLog
+)
+
src_prepare() {
epatch "${FILESDIR}"/${P}-no-automagic-debug.diff
eautoconf
}
src_configure() {
- # authentication libraries don't belong into usr,
- # please don't change this
- econf --libdir="/$(get_libdir)" \
+ # Usually, authentication libraries don't belong into usr.
+ # But here, it's required that the lib is in the same dir
+ # as libmysql, because else failures may occur on boot if
+ # udev tries to access a user / group that doesn't exist
+ # on the system before /usr is mounted.
+ econf --libdir="/usr/$(get_libdir)" \
$(use_enable debug)
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
find "${D}" -name '*.la' -delete
newdoc sample/README README.sample
- dodoc AUTHORS DEBUGGING FAQ INSTALL NEWS README THANKS \
- TODO UPGRADING ChangeLog
for subdir in sample/{linux,freebsd,complex,minimal} ; do
docinto "${subdir}"