summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/ChangeLog11
-rw-r--r--sys-apps/man/files/man-1.6f-compress.patch42
-rw-r--r--sys-apps/man/man-1.6f-r3.ebuild119
-rw-r--r--sys-apps/man/metadata.xml5
4 files changed, 175 insertions, 2 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 95d422827aa9..15aec34a137e 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/man
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.142 2008/10/02 16:52:21 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.143 2009/01/08 01:53:38 darkside Exp $
+
+*man-1.6f-r3 (08 Jan 2009)
+
+ 08 Jan 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/man-1.6f-compress.patch, metadata.xml, +man-1.6f-r3.ebuild:
+ Add new USE flag (lzma) and patch to squash automagic dep on lzma-utils, see
+ bug 205147
02 Oct 2008; Brent Baude <ranger@gentoo.org> man-1.6f-r2.ebuild:
stable ppc, bug 239117
diff --git a/sys-apps/man/files/man-1.6f-compress.patch b/sys-apps/man/files/man-1.6f-compress.patch
new file mode 100644
index 000000000000..f110acd806da
--- /dev/null
+++ b/sys-apps/man/files/man-1.6f-compress.patch
@@ -0,0 +1,42 @@
+--- configure.orig 2008-12-26 23:59:40.779042906 -0600
++++ configure 2008-12-27 00:13:15.265256215 -0600
+@@ -1012,20 +1012,25 @@
+ if test "$ans" = "true"
+ then
+ DO_COMPRESSION=true
+- compress=
+- for i in lzma bzip2 gzip bzip tzip pack compress freeze yabba
+- do
+- eval F$i=missing
+- for j in $DEFPATH
+- do
+- if test -f $j/$i
+- then
+- eval F$i=$j/$i
+- if [ x$compress = x ]; then compress=$j/$i; fi
+- break
+- fi
+- done
+- done
++ if [ x$COMPRESS != x ]; then
++ compress=$COMPRESS
++ echo $compress
++ else
++ compress=
++ for i in lzma bzip2 gzip bzip tzip pack compress freeze yabba
++ do
++ eval F$i=missing
++ for j in $DEFPATH
++ do
++ if test -f $j/$i
++ then
++ eval F$i=$j/$i
++ if [ x$compress = x ]; then compress=$j/$i; fi
++ break
++ fi
++ done
++ done
++ fi
+
+ if [ x$default = x ]; then
+ echo ""
diff --git a/sys-apps/man/man-1.6f-r3.ebuild b/sys-apps/man/man-1.6f-r3.ebuild
new file mode 100644
index 000000000000..67d9e2b08887
--- /dev/null
+++ b/sys-apps/man/man-1.6f-r3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6f-r3.ebuild,v 1.1 2009/01/08 01:53:38 darkside Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Standard commands to read man pages"
+HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
+SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="lzma nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=">=sys-apps/groff-1.19.2-r1
+ !sys-apps/man-db
+ !app-arch/lzma
+ lzma? ( app-arch/lzma-utils )"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/man-1.6f-man2html-compression.patch
+ epatch "${FILESDIR}"/man-1.6-cross-compile.patch
+ epatch "${FILESDIR}"/man-1.5p-search-order.patch
+ epatch "${FILESDIR}"/man-1.6f-unicode.patch #146315
+ epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
+ epatch "${FILESDIR}"/man-1.6b-more-sections.patch
+ epatch "${FILESDIR}"/man-1.6c-cut-duplicate-manpaths.patch
+ epatch "${FILESDIR}"/man-1.5m2-apropos.patch
+ epatch "${FILESDIR}"/man-1.6d-fbsd.patch
+ epatch "${FILESDIR}"/man-1.6e-headers.patch
+ epatch "${FILESDIR}"/man-1.6f-so-search.patch
+ epatch "${FILESDIR}"/man-1.6f-compress.patch
+
+ strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
+}
+
+src_compile() {
+ unset NLSPATH #175258
+
+ tc-export CC BUILD_CC
+
+ local mylang=
+ if use nls ; then
+ if [[ -z ${LINGUAS} ]] ; then
+ mylang="all"
+ else
+ mylang="${LINGUAS// /,}"
+ fi
+ else
+ mylang="none"
+ fi
+ if use lzma; then
+ mycompress=/usr/bin/lzma
+ else
+ mycompress=/bin/bzip2
+ fi
+ COMPRESS=$mycompress \
+ ./configure \
+ -confdir=/etc \
+ +sgid +fhs \
+ +lang ${mylang} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ unset NLSPATH #175258
+
+ emake PREFIX="${D}" install || die "make install failed"
+ dosym man /usr/bin/manpath
+
+ dodoc LSM README* TODO
+
+ # makewhatis only adds man-pages from the last 24hrs
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/makewhatis.cron makewhatis
+
+ keepdir /var/cache/man
+ diropts -m0775 -g man
+ local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
+ for x in ${mansects//:/ } ; do
+ keepdir /var/cache/man/cat${x}
+ done
+}
+
+pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man "${ROOT}"/var/cache/man
+ chmod -R g+w "${ROOT}"/var/cache/man
+ [[ -e ${ROOT}/var/cache/man/whatis ]] \
+ && chown root:0 "${ROOT}"/var/cache/man/whatis
+
+ echo
+
+ local f files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ for f in ${files} ; do
+ [[ ${f} == */etc/cron.daily/makewhatis ]] && continue
+ [[ $(md5sum "${f}") == "8b2016cc778ed4e2570b912c0f420266 "* ]] \
+ && rm -f "${f}"
+ done
+ files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ if [[ ${files/$'\n'} != ${files} ]] ; then
+ ewarn "You have multiple makewhatis cron files installed."
+ ewarn "You might want to delete all but one of these:"
+ ewarn ${files}
+ fi
+}
diff --git a/sys-apps/man/metadata.xml b/sys-apps/man/metadata.xml
index 96a2d586367d..37039b8b8144 100644
--- a/sys-apps/man/metadata.xml
+++ b/sys-apps/man/metadata.xml
@@ -2,4 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
+<use>
+ <flag name='lzma'>Uses <pkg>app-arch/lzma-utils</pkg> for the COMPRESS
+ feature. Could also be used to guarantee that lzma is on the
+ system.</flag>
+</use>
</pkgmetadata>