summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/ChangeLog6
-rw-r--r--sys-apps/file/file-4.18.ebuild26
2 files changed, 4 insertions, 28 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 523ef5347a9d..0f7802e79ea4 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,10 +1,6 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.108 2006/11/02 19:58:21 kanaka Exp $
-
- 02 Nov 2006; Joel Martin <kanaka@gentoo.org> file-4.18.ebuild:
- To cross-compile, we need to build a native version of the 'file'
- executable and then use that to build to magic data.
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.109 2006/11/02 20:39:54 kanaka Exp $
*file-4.18 (31 Oct 2006)
diff --git a/sys-apps/file/file-4.18.ebuild b/sys-apps/file/file-4.18.ebuild
index a749e782b239..6c77e19d13d2 100644
--- a/sys-apps/file/file-4.18.ebuild
+++ b/sys-apps/file/file-4.18.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.18.ebuild,v 1.4 2006/11/02 20:12:35 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.18.ebuild,v 1.5 2006/11/02 20:39:54 kanaka Exp $
-inherit eutils distutils libtool toolchain-funcs
+inherit eutils distutils libtool
DESCRIPTION="identify a file's format by scanning binary data for patterns"
HOMEPAGE="ftp://ftp.astron.com/pub/file/"
@@ -31,31 +31,11 @@ src_unpack() {
# dont let python README kill main README #60043
mv python/README{,.python}
-
- if tc-is-cross-compiler; then
- cp -rpP ${S} ${S}-native
- fi
}
src_compile() {
- local mymake=
-
- # To cross-compile we create a native build version of the 'file'
- # executable first and use it during the real build.
- if tc-is-cross-compiler; then
- cd ${S}-native
- einfo "Doing native configure"
- CC=$(tc-getBUILD_CC) econf --datadir=/usr/share/misc || die
- einfo "Doing native build of 'file'"
- CC=$(tc-getBUILD_CC) emake -C src file|| die "emake failed"
- mymake="FILE_COMPILE=${S}-native/src/file"
- export ac_cv_sizeof_uint8_t=1 ac_cv_sizeof_uint16_t=2
- export ac_cv_sizeof_uint32_t=4 ac_cv_sizeof_uint64_t=8
- cd ${S}
- einfo "Continuing with cross-compile"
- fi
econf --datadir=/usr/share/misc || die
- emake ${mymake} || die "emake failed"
+ emake || die "emake failed"
use python && cd python && distutils_src_compile
}