summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog16
-rw-r--r--sys-apps/portage/files/digest-portage-2.1.3.129
-rw-r--r--sys-apps/portage/portage-2.1.3.12.ebuild260
3 files changed, 284 insertions, 1 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index a49391fce520..0e626dd3f5bb 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.447 2007/09/30 04:11:34 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.448 2007/10/06 04:19:11 zmedico Exp $
+
+*portage-2.1.3.12 (06 Oct 2007)
+
+ 05 Oct 2007; Zac Medico <zmedico@gentoo.org> +portage-2.1.3.12.ebuild:
+ 2.1.3.12 bump. This fixes bugs #88613, #142508, #174405, 174410,
+ #179380, #194095, #194169, #194398, #194764, and #194876. Bug #194041
+ tracks all bugs fixed since 2.1.3.9. This release is the first to have
+ support for EAPI-1 (#194876), which includes SLOT dependencies
+ (#174405), IUSE defaults (#174410), and ECONF_SOURCE support for the
+ default src_compile function (#179380). Package maintainers should
+ carefully consider the backward compatibility consequences before
+ defining EAPI="1" in any ebuilds, especially if other packages depend
+ on those ebuilds. See the ebuild(5) and emerge(1) manual pages for
+ EAPI related documentation.
30 Sep 2007; Zac Medico <zmedico@gentoo.org> -portage-2.1.2.2.ebuild,
-portage-2.1.2.9.ebuild, -portage-2.1.2.11.ebuild:
diff --git a/sys-apps/portage/files/digest-portage-2.1.3.12 b/sys-apps/portage/files/digest-portage-2.1.3.12
new file mode 100644
index 000000000000..6ed9ca7e26b9
--- /dev/null
+++ b/sys-apps/portage/files/digest-portage-2.1.3.12
@@ -0,0 +1,9 @@
+MD5 5b9cbd786c52fb2669d54c3c21656a6f portage-2.1.3.12.patch.bz2 50329
+RMD160 c3ed8995bcff846ae515ce77d6454d9976adb287 portage-2.1.3.12.patch.bz2 50329
+SHA256 a04cfeb10db92b153b5218c6066fdf1264c4b2bad2ccd1432e3d5e350cd55c44 portage-2.1.3.12.patch.bz2 50329
+MD5 c8b48f9de6763a020dd9a44c695668a3 portage-2.1.3.tar.bz2 356902
+RMD160 064ec10181e3b7f6727810b83dbd1c1d2c9b0462 portage-2.1.3.tar.bz2 356902
+SHA256 6f06dfebc7a626e88af6a7c99d4c1c380a6ae0ad4adede7cdf2510ba04c43883 portage-2.1.3.tar.bz2 356902
+MD5 6409f79dd5efe7922dd8fa36340c4912 portage-man-pl-2.1.2.tar.bz2 53893
+RMD160 46c3656b40bf4ad2530ab2b5fbc563708b86748c portage-man-pl-2.1.2.tar.bz2 53893
+SHA256 960eaa7c6f3a2af44bdc665266a8e884628a562373cc477d301597ecc5ef961f portage-man-pl-2.1.2.tar.bz2 53893
diff --git a/sys-apps/portage/portage-2.1.3.12.ebuild b/sys-apps/portage/portage-2.1.3.12.ebuild
new file mode 100644
index 000000000000..4f879dea2e29
--- /dev/null
+++ b/sys-apps/portage/portage-2.1.3.12.ebuild
@@ -0,0 +1,260 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.3.12.ebuild,v 1.1 2007/10/06 04:19:11 zmedico Exp $
+
+inherit toolchain-funcs eutils flag-o-matic multilib
+
+DESCRIPTION="The Portage Package Management System. The primary package management and distribution system for Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+PROVIDE="virtual/portage"
+SLOT="0"
+# USE_EXPAND_HIDDEN hides ELIBC and USERLAND expansions from emerge output (see make.conf.5).
+IUSE_ELIBC="elibc_glibc elibc_uclibc elibc_FreeBSD"
+IUSE="build doc epydoc selinux linguas_pl userland_GNU ${IUSE_ELIBC}"
+DEPEND=">=dev-lang/python-2.4
+ !build? ( >=sys-apps/sed-4.0.5 )
+ doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+ epydoc? ( >=dev-python/epydoc-2.0 )"
+RDEPEND=">=dev-lang/python-2.4
+ !build? ( >=sys-apps/sed-4.0.5
+ >=app-shells/bash-3.1_p17 )
+ elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
+ elibc_glibc? ( >=sys-apps/sandbox-1.2.17 )
+ elibc_uclibc? ( >=sys-apps/sandbox-1.2.17 )
+ >=app-misc/pax-utils-0.1.13
+ selinux? ( >=dev-python/python-selinux-2.16 )"
+PDEPEND="
+ doc? (
+ || ( app-portage/eclass-manpages app-portage/portage-manpages )
+ )
+ !build? (
+ >=net-misc/rsync-2.6.4
+ userland_GNU? ( >=sys-apps/coreutils-6.4 )
+ || ( >=dev-lang/python-2.5 >=dev-python/pycrypto-2.0.1-r6 )
+ )"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# rsync-2.6.4 rdep is for the --filter option #167668
+SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
+
+PV_PL="2.1.2"
+PATCHVER_PL=""
+TARBALL_PV="${PV%.*}"
+SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
+ ${SRC_ARCHIVES}/${PN}-${TARBALL_PV}.tar.bz2
+ linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
+ ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}.tar.bz2 )"
+
+PATCHVER="${PVR}"
+if [ -n "${PATCHVER}" ]; then
+ SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PATCHVER}.patch.bz2
+ ${SRC_ARCHIVES}/${PN}-${PATCHVER}.patch.bz2"
+fi
+
+if [ -n "${PATCHVER_PL}" ]; then
+ SRC_URI="${SRC_URI} linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2
+ ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2 )"
+fi
+
+S="${WORKDIR}"/${PN}-${TARBALL_PV}
+S_PL="${WORKDIR}"/${PN}-${PV_PL}
+
+portage_docs() {
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if [ -n "${PATCHVER}" ]; then
+ cd "${S}"
+ epatch "${WORKDIR}/${PN}-${PATCHVER}.patch"
+ fi
+ einfo "Setting portage.VERSION to ${PVR} ..."
+ sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
+ die "Failed to patch portage.VERSION"
+ eend 0
+ if [ -n "${PATCHVER_PL}" ]; then
+ use linguas_pl && \
+ epatch "${WORKDIR}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch"
+ fi
+}
+
+src_compile() {
+ append-lfs-flags
+
+ cd "${S}"/src
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tbz2tool tbz2tool.c || \
+ die "Failed to build tbz2tool"
+
+ if use doc; then
+ cd "${S}"/doc
+ touch fragment/date
+ sed -i "s/svn-trunk/${PVR}/" fragment/version
+ make xhtml-nochunks || die "failed to make docs"
+ fi
+
+ if use epydoc; then
+ einfo "Generating api docs"
+ mkdir "${WORKDIR}"/api
+ local my_modules
+ my_modules="$(find "${S}/pym" -name "*.py" \
+ | sed -e 's:/__init__.py$::' -e 's:\.py$::' -e "s:^${S}/pym/::" \
+ -e 's:/:.:g')" || die "error listing modules"
+ PYTHONPATH="${S}/pym:${PYTHONPATH}" epydoc -o "${WORKDIR}"/api \
+ -qqqqq --ignore-param-mismatch --no-frames --show-imports \
+ --name "${PN}" --url "${HOMEPAGE}" \
+ ${my_modules} || die "epydoc failed"
+ fi
+}
+
+src_test() {
+ ./tests/runTests || \
+ die "test(s) failed"
+}
+
+src_install() {
+ local libdir=$(get_libdir)
+ local portage_base="/usr/${libdir}/portage"
+ cd "${S}"/cnf
+ insinto /etc
+ doins etc-update.conf dispatch-conf.conf make.globals
+ if [ -f "make.conf.${ARCH}".diff ]; then
+ patch make.conf "make.conf.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ newins make.conf make.conf.example
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ newins make.conf make.conf.example
+ fi
+
+ insinto /etc/logrotate.d
+ doins "${S}"/cnf/logrotate.d/elog-save-summary
+
+ dodir ${portage_base}/bin
+ exeinto ${portage_base}/bin
+ # BSD and OSX need a sed wrapper so that find/xargs work properly
+ if use userland_GNU; then
+ rm "${S}"/bin/sed || die "Failed to remove sed wrapper"
+ fi
+ cd "${S}"/bin
+ doexe *
+ doexe "${S}"/src/tbz2tool
+ dosym newins ${portage_base}/bin/donewins
+
+ for mydir in pym pym/cache pym/elog_modules; do
+ dodir ${portage_base}/${mydir}
+ insinto ${portage_base}/${mydir}
+ cd "${S}"/${mydir}
+ doins *.py
+ done
+
+ doman "${S}"/man/*.[0-9]
+ if use linguas_pl; then
+ doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
+ doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
+ fi
+ dodoc "${S}"/ChangeLog
+ dodoc "${S}"/NEWS
+ dodoc "${S}"/RELEASE-NOTES
+ use doc && dohtml "${S}"/doc/*.html
+ use epydoc && dohtml -r "${WORKDIR}"/api
+
+ dodir /usr/bin
+ for x in ebuild emerge portageq repoman tbz2tool xpak; do
+ dosym ../${libdir}/portage/bin/${x} /usr/bin/${x}
+ done
+
+ dodir /usr/sbin
+ local my_syms="archive-conf
+ dispatch-conf
+ emaint
+ emerge-webrsync
+ env-update
+ etc-update
+ fixpackages
+ quickpkg
+ regenworld"
+ local x
+ for x in ${my_syms}; do
+ dosym ../${libdir}/portage/bin/${x} /usr/sbin/${x}
+ done
+ dosym env-update /usr/sbin/update-env
+ dosym etc-update /usr/sbin/update-etc
+
+ dodir /etc/portage
+ keepdir /etc/portage
+
+ echo PYTHONPATH=\"${portage_base}/pym\" > "${WORKDIR}"/05portage.envd
+ doenvd "${WORKDIR}"/05portage.envd
+}
+
+pkg_preinst() {
+ local portage_base="/usr/$(get_libdir)/portage"
+ if has livecvsportage ${FEATURES} && [ "${ROOT}" = "/" ]; then
+ rm -rf "${D}"/${portage_base}/pym/*
+ mv "${D}"/${portage_base}/bin/tbz2tool "${T}"
+ rm -rf "${D}"/${portage_base}/bin/*
+ mv "${T}"/tbz2tool "${D}"/${portage_base}/bin/
+ fi
+}
+
+pkg_postinst() {
+ local x
+
+ if [ ! -f "${ROOT}/var/lib/portage/world" ] &&
+ [ -f "${ROOT}"/var/cache/edb/world ] &&
+ [ ! -h "${ROOT}"/var/cache/edb/world ]; then
+ mv "${ROOT}"/var/cache/edb/world "${ROOT}"/var/lib/portage/world
+ ln -s ../../lib/portage/world /var/cache/edb/world
+ fi
+
+ for x in "${ROOT}"/etc/._cfg????_make.globals; do
+ # Overwrite the globals file automatically.
+ [ -e "${x}" ] && mv -f "${x}" "${ROOT}etc/make.globals"
+ done
+
+ # Compile all source files recursively. Any orphans
+ # will be identified and removed in postrm.
+ compile_all_python_bytecodes "${ROOT}usr/$(get_libdir)/portage/pym"
+
+ elog
+ elog "FEATURES=\"userfetch\" is now enabled by default. Depending on your \${DISTDIR}"
+ elog "permissions, this may result in Permission Denied errors. If you would like"
+ elog "to fetch with superuser privileges, add FEATURES=\"-userfetch\" to make.conf."
+ elog
+ elog "The world file now supports slot atoms such as 'sys-devel/gcc:3.4'. In some"
+ elog "cases, emerge --depclean may remove slots that it would not have removed"
+ elog "in the past. The emerge --noreplace command can be used to add an atom to"
+ elog "the world file and prevent matching packages from being removed. A slot"
+ elog "atom will be recorded in the world file for any atom that is precise enough"
+ elog "to identify a specific slot."
+
+ portage_docs
+}
+
+pkg_postrm() {
+ remove_orphan_python_bytecodes "${ROOT}usr/$(get_libdir)/portage/pym"
+}
+
+compile_all_python_bytecodes() {
+ python -c "from compileall import compile_dir; compile_dir('${1}', quiet=True)"
+ python -O -c "from compileall import compile_dir; compile_dir('${1}', quiet=True)"
+}
+
+remove_orphan_python_bytecodes() {
+ [[ -d ${1} ]] || return
+ find "${1}" -name '*.py[co]' -print0 | \
+ while read -d $'\0' f ; do
+ src_py=${f%[co]}
+ [[ -f ${src_py} ]] && continue
+ rm -f "${src_py}"[co]
+ done
+}