summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/slocate/ChangeLog13
-rw-r--r--sys-apps/slocate/Manifest4
-rw-r--r--sys-apps/slocate/files/digest-slocate-2.7-r11
-rw-r--r--sys-apps/slocate/slocate-2.7-r1.ebuild72
4 files changed, 87 insertions, 3 deletions
diff --git a/sys-apps/slocate/ChangeLog b/sys-apps/slocate/ChangeLog
index 27e69463f48f..7b2566f1f982 100644
--- a/sys-apps/slocate/ChangeLog
+++ b/sys-apps/slocate/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-apps/slocate
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.11 2003/04/12 16:22:11 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.12 2003/04/12 16:33:54 seemant Exp $
+
+*slocate-2.7-r1 (12 Apr 2003)
+
+ 12 Apr 2003; Seemant Kulleen <seemant@gentoo.org> Manifest,
+ slocate-2.7-r1.ebuild:
+ OK, I bumped the version just because of people worrying about the bogus error
+ messages that slocate puts out when first run. For instance without a db file,
+ locate will error out. With a blank db file, it will report nothing, as
+ expected. So, we check if a db file exists, if not, we install a blank one.
+ Additionally, slocate cries about an update.conf file, so we just create a
+ blank one with a note pointing to the sample one in the doc folder.
*slocate-2.7 (02 Feb 2003)
diff --git a/sys-apps/slocate/Manifest b/sys-apps/slocate/Manifest
index 6e617d4bd381..4762f0c8613b 100644
--- a/sys-apps/slocate/Manifest
+++ b/sys-apps/slocate/Manifest
@@ -1,7 +1,7 @@
MD5 deed52f5c90674617b64da43fdb30719 slocate-2.7.ebuild 1790
-MD5 57f7206b5ddf32ba36f09f9d5a4afa3d slocate-2.7-r1.ebuild 1993
+MD5 035b3ba42bb0c50851e6c1180300c783 slocate-2.7-r1.ebuild 1996
MD5 c70139b84478e8c4a547eb310a9c8770 slocate-2.6.ebuild 1543
-MD5 99cc61f71f28b7d894afc57dc457c056 ChangeLog 1247
+MD5 883e281d9fa598322341e3ca2f64d76f ChangeLog 1827
MD5 2831adc800599b2ae5ee340beafc4e31 files/digest-slocate-2.6 62
MD5 f03ed3063ac796dbf26187038a928db8 files/digest-slocate-2.7 62
MD5 cd00fa09325061c98ee3f81fefa61014 files/updatedb.conf 578
diff --git a/sys-apps/slocate/files/digest-slocate-2.7-r1 b/sys-apps/slocate/files/digest-slocate-2.7-r1
new file mode 100644
index 000000000000..f312912325b1
--- /dev/null
+++ b/sys-apps/slocate/files/digest-slocate-2.7-r1
@@ -0,0 +1 @@
+MD5 4872830642ea2ed5f9aff932720583c9 slocate-2.7.tar.gz 87240
diff --git a/sys-apps/slocate/slocate-2.7-r1.ebuild b/sys-apps/slocate/slocate-2.7-r1.ebuild
new file mode 100644
index 000000000000..9f964a471fab
--- /dev/null
+++ b/sys-apps/slocate/slocate-2.7-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.7-r1.ebuild,v 1.1 2003/04/12 16:33:54 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Secure locate provides a secure way to index and quickly search for files on your system (drop-in replacement for 'locate')"
+HOMEPAGE="http://www.geekreview.org/slocate/"
+SRC_URI="ftp://ftp.geekreview.org/slocate/src/slocate-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc ~alpha ~hppa ~mips"
+
+DEPEND="virtual/glibc"
+
+src_install() {
+
+ dodir /usr/share/man/man1
+
+ make DESTDIR=${D} install || die
+
+ # make install for this package is blocked by sandbox
+# dobin slocate
+ dosym slocate /usr/bin/locate
+ dosym slocate /usr/bin/updatedb
+ fperms 0755 /etc/cron.daily/slocate
+#
+# dosym slocate.1.gz /usr/share/man/man1/locate.1.gz
+#
+ keepdir /var/lib/slocate
+
+
+ # If this file doesn't exist, the first run of updatedb will create
+ # it anyway. But doing this shuts it up.
+ if [ ! -f ${ROOT}/var/lib/slocate/slocate.db ]
+ then
+ touch ${D}/var/lib/slocate/slocate.db
+ fi
+
+ dodoc INSTALL LICENSE COPYING AUTHORS NEWS README ChangeLog
+
+
+ # man page fixing
+ rm -rf ${D}/usr/share/man/man1/locate.1.gz
+ dosym slocate.1.gz /usr/share/man/man1/locate.1.gz
+
+
+ # Make a fake updatedb.conf file, to shut slocate up
+ echo "# There is a sample config file in :" > updatedb.conf
+ echo "# /usr/share/doc/${P}/updatedb.conf.gz" >> updatedb.conf
+ insinto /etc
+ doins updatedb.conf
+ fperms 0644 /etc/updatedb.conf
+
+ dodoc ${FILESDIR}/updatedb.conf
+}
+
+pkg_postinst() {
+ # /var/lib/slocate is owned by group slocate and so is the executable
+ groupadd slocate
+
+ chown root.slocate /usr/bin/slocate
+ chmod 2755 /usr/bin/slocate
+
+ chown -R root.slocate /var/lib/slocate
+ chmod 0750 /var/lib/slocate
+
+ einfo "Please note that the /etc/updatedb.conf file is EMPTY"
+ einfo "There is a sample configuration file in"
+ einfo "/usr/share/doc/${P}"
+
+}