summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/utempter/files/utempter-0.5.5.5-soname-makefile-fix.patch')
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.5-soname-makefile-fix.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-apps/utempter/files/utempter-0.5.5.5-soname-makefile-fix.patch b/sys-apps/utempter/files/utempter-0.5.5.5-soname-makefile-fix.patch
new file mode 100644
index 000000000000..ae50456a987f
--- /dev/null
+++ b/sys-apps/utempter/files/utempter-0.5.5.5-soname-makefile-fix.patch
@@ -0,0 +1,23 @@
+diff -urN utempter-0.5.3.orig/Makefile utempter-0.5.3/Makefile
+--- utempter-0.5.3.orig/Makefile 2004-04-07 23:02:39.000000000 -0400
++++ utempter-0.5.3/Makefile 2004-04-07 23:04:33.000000000 -0400
+@@ -5,6 +5,10 @@
+ CVSROOT=$(shell cat CVS/Root)
+ # major number of the .so lib
+ SOMAJOR = 0
++# minor number of the .so lib
++SOMINOR = 5
++# major number of the .so lib
++SOMICRO = 3
+
+ SHAREDLIB = lib$(NAME).so
+ SONAME = $(SHAREDLIB).$(SOMAJOR)
+@@ -29,6 +33,8 @@
+ install -m 644 utempter.h $(RPM_BUILD_ROOT)/usr/include
+ install -m 644 $(SHAREDLIB) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(VERSION)
+ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB)
++ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(SOMAJOR).$(SOMINOR)
++ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(SOMAJOR)
+
+ $(SHAREDLIB): utmpintf.os
+ $(CC) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc