summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/tcb/tcb-1.0-r1.ebuild')
-rw-r--r--sys-apps/tcb/tcb-1.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/tcb/tcb-1.0-r1.ebuild b/sys-apps/tcb/tcb-1.0-r1.ebuild
new file mode 100644
index 000000000000..ac52ef1247fe
--- /dev/null
+++ b/sys-apps/tcb/tcb-1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/tcb-1.0-r1.ebuild,v 1.1 2007/01/12 03:13:39 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme"
+HOMEPAGE="http://www.openwall.com/tcb/"
+SRC_URI="ftp://ftp.openwall.com/pub/projects/tcb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="pam"
+
+DEPEND="pam? ( >=sys-libs/pam-0.75 )"
+
+pkg_setup() {
+ for group in auth chkpwd shadow ; do
+ enewgroup ${group}
+ done
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -i "s:@GENTOO_LIBDIR@:$(get_libdir):" Make.defs
+ use pam || sed -i '/pam/d' Makefile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ einfo "You must now run /sbin/tcb_convert to convert your shadow to tcb"
+ einfo "To remove this you must first run /sbin/tcp_unconvert and then unmerge"
+}