summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog7
-rw-r--r--sys-apps/sg3_utils/files/digest-sg3_utils-1.243
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.24.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 5b21f907d8e6..0d1bef7f77f3 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.27 2007/03/08 19:41:11 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.28 2007/05/24 07:00:50 robbat2 Exp $
+
+*sg3_utils-1.24 (24 May 2007)
+
+ 24 May 2007; Robin H. Johnson <robbat2@gentoo.org> +sg3_utils-1.24.ebuild:
+ Version bump. Break rescan-scsi-bus back out to a seperate package.
08 Mar 2007; Gustavo Zacarias <gustavoz@gentoo.org> sg3_utils-1.23.ebuild:
Stable on sparc
diff --git a/sys-apps/sg3_utils/files/digest-sg3_utils-1.24 b/sys-apps/sg3_utils/files/digest-sg3_utils-1.24
new file mode 100644
index 000000000000..c51ddc07d95f
--- /dev/null
+++ b/sys-apps/sg3_utils/files/digest-sg3_utils-1.24
@@ -0,0 +1,3 @@
+MD5 8ca3f643057855bf98b9487f96ea486c sg3_utils-1.24.tgz 536253
+RMD160 b23ba8e96918b7c111a4178d06c5b3bce2b62ae5 sg3_utils-1.24.tgz 536253
+SHA256 b3798f845523d4e9858434ae468db2341547c8a58876c7c83e9fd84f82ce05d9 sg3_utils-1.24.tgz 536253
diff --git a/sys-apps/sg3_utils/sg3_utils-1.24.ebuild b/sys-apps/sg3_utils/sg3_utils-1.24.ebuild
new file mode 100644
index 000000000000..21ac76bfe445
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.24.ebuild,v 1.1 2007/05/24 07:00:50 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="apps for querying the sg SCSI interface (contains rescan_scsi_bus.sh)"
+HOMEPAGE="http://www.torque.net/sg/"
+SRC_URI="http://www.torque.net/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_unpack() {
+ unpack ${P}.tgz
+ cd "${S}"
+ for i in Makefile utils/Makefile ; do
+ sed -i \
+ -e '/^CFLAGS/s:= -g -O2:+=:' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e '/^PREFIX=/s:/local::' \
+ -e 's:$(DESTDIR)/:$(DESTDIR):' \
+ -e "/^LIBDIR=/s:/lib$:/$(get_libdir):" \
+ -e '/^MANDIR=/s:)/man:)/share/man:' \
+ -e '/ install /s: -s : :' \
+ $i || die "sed of $i failed"
+ done
+}
+
+src_compile() {
+ emake || die "emake failed"
+ emake -C utils || die "emake utils failed"
+}
+
+src_install() {
+ dodoc examples/*.txt CHANGELOG COVERAGE CREDITS README*
+ dohtml doc/*html
+ make install DESTDIR="${D}" || die "make install failed"
+ make -C utils install DESTDIR="${D}" || die "make install failed"
+}