summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index eb5ab3d0a5e2..263dd20a9709 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.110 2012/10/17 16:57:56 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.111 2012/10/18 15:03:19 williamh Exp $
EAPI=4
@@ -439,9 +439,11 @@ pkg_postinst() {
local netscript=net.lo
fi
- ewarn "Please add the $netscript script to your boot runlevel"
- ewarn "as soon as possible. Not doing so could leave you with a system"
- ewarn "without networking."
+ if [ ! -e "${EROOT}"/etc/runlevels/boot/${netscript} ]; then
+ ewarn "Please add the $netscript script to your boot runlevel"
+ ewarn "as soon as possible. Not doing so could leave you with a system"
+ ewarn "without networking."
+ fi
elog "You should now update all files in /etc, using etc-update"
elog "or equivalent before restarting any services or this host."