summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/lvm-user/lvm-user-1.0.5.ebuild')
-rw-r--r--sys-apps/lvm-user/lvm-user-1.0.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/lvm-user/lvm-user-1.0.5.ebuild b/sys-apps/lvm-user/lvm-user-1.0.5.ebuild
new file mode 100644
index 000000000000..4ab7b31b6606
--- /dev/null
+++ b/sys-apps/lvm-user/lvm-user-1.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lvm-user/lvm-user-1.0.5.ebuild,v 1.1 2002/08/01 18:26:04 aliz Exp $
+
+S=${WORKDIR}/LVM/${PV}
+DESCRIPTION="User-land utilities for LVM (Logical Volume Manager) software"
+SRC_URI="ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${PV}.tar.gz"
+HOMEPAGE="http://www.sistina.com/"
+KEYWORDS="x86 -ppc"
+
+DEPEND="virtual/glibc
+ virtual/linux-sources"
+RDEPEND="virtual/glibc"
+LICENSE="GPL-2 LGPL"
+SLOT="0"
+
+KS=/usr/src/linux
+
+src_compile() {
+ cd ${S}
+ #This ebuild doesn't like this opt setting; closes bug #598
+ export CFLAGS="${CFLAGS/-fomit-frame-pointer/}"
+ [ -f "Makefile" ] && ( make clean || die )
+ CFLAGS="${CFLAGS} -I${KS}/include" \
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --with-kernel_dir="${KS}" || die
+ make || die
+}
+
+src_install() {
+ cd ${S}/tools
+ CFLAGS="${CFLAGS} -I${KS}/include" \
+ make install \
+ -e prefix=${D} \
+ mandir=${D}/usr/share/man \
+ sbindir=${D}/sbin \
+ libdir=${D}/lib || die
+ #no need for a static library in /lib
+ dodir /usr/lib
+ mv ${D}/lib/*.a ${D}/usr/lib
+ cd ${S}
+ dodoc ABSTRACT CHANGELOG CONTRIBUTORS COPYING COPYING.LIB KNOWN_BUGS FAQ INSTALL LVM-HOWTO README TODO WHATSNEW
+}
+