summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ed/ed-0.2-r5.ebuild')
-rw-r--r--sys-apps/ed/ed-0.2-r5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/ed/ed-0.2-r5.ebuild b/sys-apps/ed/ed-0.2-r5.ebuild
new file mode 100644
index 000000000000..eb43f8f52c98
--- /dev/null
+++ b/sys-apps/ed/ed-0.2-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r5.ebuild,v 1.1 2005/01/09 10:48:41 robbat2 Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/ed/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-info-dir.patch
+ epatch ${FILESDIR}/${PV}-r5-mkstemp.patch
+ chmod 755 configure #73575
+ WANT_AUTOCONF=2.1 autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ export CC="$(tc-getCC)" RANLIB="$(tc-getRANLIB)"
+ # very old configure script ... econf wont work
+ local myconf="--prefix=/ --host=${CHOST}"
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+ [[ -n ${CTARGET} ]] && myconf="${myconf} --target=${CTARGET}"
+ myconf="${myconf} ${EXTRA_ECONF}"
+ echo "./configure ${myconf}"
+ ./configure ${myconf} || die
+ emake AR="$(tc-getAR)" || die
+}
+
+src_install() {
+ chmod 0644 ${S}/ed.info
+ make \
+ prefix=${D}/ \
+ mandir=${D}/usr/share/man/man1 \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc ChangeLog NEWS POSIX README THANKS TODO
+}