summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild')
-rw-r--r--sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild b/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild
new file mode 100644
index 000000000000..4805b16820bd
--- /dev/null
+++ b/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpufreqd/cpufreqd-1.1.1.ebuild,v 1.1 2004/02/08 19:09:07 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Daemon to adjust CPU speed for power saving"
+HOMEPAGE="http://sourceforge.net/projects/cpufreqd/"
+SRC_URI="mirror://sourceforge/cpufreqd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i '/^DAEMON=/s:/sbin/:/usr/sbin/:' scripts/gentoo/cpufreqd
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README Authors TODO
+
+ exeinto /etc/init.d
+ newexe ${S}/scripts/gentoo/cpufreqd cpufreqd
+}
+
+pkg_postinst() {
+ echo
+ einfo "A default config file has been copied to /etc/cpufreqd.conf"
+ echo
+ einfo "CPUFreqd does not support using percentage frequencies on"
+ einfo "2.6 kernels where sysfs is used instead - please manually"
+ einfo "edit the config file to use an absolute value instead, if"
+ einfo "you are using a 2.6 series kernel."
+ echo
+}