summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/attr/attr-2.4.7.ebuild')
-rw-r--r--sys-apps/attr/attr-2.4.7.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/attr/attr-2.4.7.ebuild b/sys-apps/attr/attr-2.4.7.ebuild
new file mode 100644
index 000000000000..93cb403ac0da
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.7.ebuild,v 1.1 2003/08/12 01:42:46 robbat2 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ http://acl.bestbits.at/current/tar/${P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~amd64 ~mips ~ppc"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
+ virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-devel/gcc-3*"
+RDEPEND="virtual/glibc"
+
+IUSE="nls debug"
+
+src_compile() {
+ if use debug; then
+ DEBUG=-DDEBUG
+ OPTIMIZER="-g"
+ CFLAGS=
+ CXXFLAGS=
+ export DEBUG OPTIMIZER CFLAGS CXXFLAGS
+ else
+ DEBUG=-DNDEBUG
+ OPTIMIZER=""
+ # note that CFLAGS is already inherited!
+ export DEBUG OPTIMIZER
+ fi
+
+ local myconf="`use_enable nls gettext`"
+ econf ${myconf} || die
+
+ sed -i \
+ -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e 's:-O1::' -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs
+
+ make || die
+}
+
+src_install() {
+ make DIST_ROOT=${D} \
+ install install-lib install-dev || die
+
+ # install docs in correct place
+ mv ${D}/usr/share/doc/attr ${D}/usr/share/doc/${PF}
+ prepalldocs
+
+ dodir /lib
+ dosym /usr/lib/libattr.a /lib/libattr.a
+ dosym /usr/lib/libattr.la /lib/libattr.la
+ dosym /lib/libattr.so /usr/lib/libattr.so
+ dosym libattr.so.1 /usr/lib/libattr.so
+}