summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/geomview/geomview-1.9.4.ebuild')
-rw-r--r--sci-mathematics/geomview/geomview-1.9.4.ebuild47
1 files changed, 25 insertions, 22 deletions
diff --git a/sci-mathematics/geomview/geomview-1.9.4.ebuild b/sci-mathematics/geomview/geomview-1.9.4.ebuild
index f55efbc40c67..9a18a8a015c8 100644
--- a/sci-mathematics/geomview/geomview-1.9.4.ebuild
+++ b/sci-mathematics/geomview/geomview-1.9.4.ebuild
@@ -1,38 +1,42 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/geomview/geomview-1.9.4.ebuild,v 1.6 2010/10/10 21:49:01 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/geomview/geomview-1.9.4.ebuild,v 1.7 2012/01/26 17:10:25 jlec Exp $
EAPI=1
inherit elisp-common eutils flag-o-matic fdo-mime
DESCRIPTION="Interactive Geometry Viewer"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
HOMEPAGE="http://geomview.sourceforge.net"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ http://dev.gentoo.org/~jlec/distfiles/geomview.png.tar"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
LICENSE="LGPL-2.1"
SLOT="0"
IUSE="avg bzip2 debug emacs netpbm pdf zlib"
-DEPEND="zlib? ( sys-libs/zlib )
- emacs? ( virtual/emacs )
+DEPEND="
>=x11-libs/openmotif-2.3:0
- virtual/opengl"
-
+ virtual/opengl
+ emacs? ( virtual/emacs )
+ zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}
- netpbm? ( >=media-libs/netpbm-10.37.0 )
- bzip2? ( app-arch/bzip2 )
app-arch/gzip
- pdf? ( || ( app-text/xpdf
- app-text/gv
- app-text/gsview
- app-text/epdfview
- app-text/acroread )
- )
- virtual/w3m"
+ virtual/w3m
+ bzip2? ( app-arch/bzip2 )
+ netpbm? ( >=media-libs/netpbm-10.37.0 )
+ pdf? (
+ || ( app-text/xpdf
+ app-text/gv
+ app-text/gsview
+ app-text/epdfview
+ app-text/acroread )
+ )"
S="${WORKDIR}/${P/_/-}"
+
SITEFILE=50${PN}-gentoo.el
src_compile() {
@@ -45,8 +49,7 @@ src_compile() {
fi
econf ${myconf} $(use_enable debug d1debug) $(use_with zlib) \
- $(use_enable avg motion-averaging) \
- || die "could not configure"
+ $(use_enable avg motion-averaging)
emake || die "make failed"
@@ -60,15 +63,15 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- doicon "${FILESDIR}"/geomview.png
+ doicon "${WORKDIR}"/geomview.png || die
make_desktop_entry geomview "GeomView ${PV}" \
"/usr/share/pixmaps/geomview.png" \
"Science;Math;Education"
- dodoc AUTHORS ChangeLog NEWS INSTALL.Geomview
+ dodoc AUTHORS ChangeLog NEWS INSTALL.Geomview || die
if ! use pdf; then
- rm "${D}"/usr/share/doc/${PF}/${PN}.pdf
+ rm "${D}"/usr/share/doc/${PF}/${PN}.pdf || die
fi
if use emacs; then
@@ -83,7 +86,7 @@ pkg_postinst() {
elog "GeomView expects you to have both Firefox and Xpdf installed for"
elog "viewing the documentation (this can be changed at runtime)."
- elog ""
+ echo ""
elog "The w3m virtual should handle the HTML browser part, and if"
elog "you wish to use an alternate PDF viewer, feel free to remove"
elog "xpdf and use the viewer of your choice (see the docs for how"