summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libgeda/ChangeLog6
-rw-r--r--sci-libs/libgeda/libgeda-1.4.1.ebuild72
-rw-r--r--sci-libs/libgeda/libgeda-1.4.3-r1.ebuild56
-rw-r--r--sci-libs/libgeda/libgeda-1.4.3.ebuild73
4 files changed, 5 insertions, 202 deletions
diff --git a/sci-libs/libgeda/ChangeLog b/sci-libs/libgeda/ChangeLog
index 2b03cd4a2a4b..52b00fdcc9ac 100644
--- a/sci-libs/libgeda/ChangeLog
+++ b/sci-libs/libgeda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libgeda
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.52 2010/05/23 18:52:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.53 2010/08/21 21:12:40 flameeyes Exp $
+
+ 21 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -libgeda-1.4.1.ebuild, -libgeda-1.4.3.ebuild, -libgeda-1.4.3-r1.ebuild:
+ Remove non-stable versions as per masking.
23 May 2010; Raúl Porcel <armin76@gentoo.org> libgeda-1.4.3-r1.ebuild:
sparc stable wrt #285493
diff --git a/sci-libs/libgeda/libgeda-1.4.1.ebuild b/sci-libs/libgeda/libgeda-1.4.1.ebuild
deleted file mode 100644
index 29729651ecca..000000000000
--- a/sci-libs/libgeda/libgeda-1.4.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.4.1.ebuild,v 1.1 2008/12/01 14:18:26 calchan Exp $
-
-inherit eutils fdo-mime versionator
-
-SUBDIR="v$(get_version_component_range 1-2)"
-
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE="gd threads"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-SLOT="0"
-
-DEPEND=">=x11-libs/gtk+-2.4
- >=dev-scheme/guile-1.6.3
- >=dev-libs/libstroke-0.5.1
- gd? ( >=media-libs/gd-2 )"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
- if use gd ; then
- built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # Skip the share sub-directory, we'll install prolog.ps manually
- sed -i \
- -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
- "${S}"/Makefile.in \
- || die "Patch failed"
-}
-
-src_compile() {
- local myconf="--disable-threads"
- use threads || myconf="--enable-threads=posix"
- econf \
- ${myconf} \
- --disable-dependency-tracking \
- --disable-rpath \
- --disable-update-mime-database \
- --with-x \
- $(use_enable gd) \
- || die "Configuration failed"
- emake || die "Compilation failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- insinto /usr/share/gEDA
- doins share/prolog.ps
-
- dodoc AUTHORS BUGS ChangeLog README
-}
-
-src_postinst() {
- fdo-mime_mime_database_update
-}
-
-src_postrm() {
- fdo-mime_mime_database_update
-}
diff --git a/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild b/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild
deleted file mode 100644
index 026fb8a31b40..000000000000
--- a/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.4.3-r1.ebuild,v 1.6 2010/05/23 18:52:09 armin76 Exp $
-
-EAPI="2"
-
-inherit fdo-mime versionator
-
-DESCRIPTION="GPL Electronic Design Automation: core library"
-HOMEPAGE="http://www.gpleda.org/"
-SRC_URI="http://geda.seul.org/release/v$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="nls threads"
-
-RDEPEND=">=dev-libs/glib-2.4
- >=x11-libs/gtk+-2.4
- || ( =dev-scheme/guile-1.6* =dev-scheme/guile-1.8*[deprecated] )
- nls? ( virtual/libintl )"
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=dev-util/pkgconfig-0.9
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- # for gEDA 1.4.3 make doxygen does not work
- sed -i -e 's/ docs / /' Makefile.in || die "sed failed"
-}
-
-src_configure() {
- # nls may not work if LINGUAS is set -- upstream bug, they use only variants
- # like de_DE.po. See Debian bug #336796
- use nls && unset LINGUAS
- econf \
- $(use_enable threads threads posix) \
- $(use_enable nls) \
- --disable-dependency-tracking \
- --disable-rpath \
- --disable-update-mime-database
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc README AUTHORS NEWS BUGS
-}
-
-pkg_postinst() {
- fdo-mime_mime_database_update
-}
-
-pkg_postrm() {
- fdo-mime_mime_database_update
-}
diff --git a/sci-libs/libgeda/libgeda-1.4.3.ebuild b/sci-libs/libgeda/libgeda-1.4.3.ebuild
deleted file mode 100644
index 68cfb1b0ab58..000000000000
--- a/sci-libs/libgeda/libgeda-1.4.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.4.3.ebuild,v 1.1 2009/03/07 21:33:17 patrick Exp $
-
-inherit eutils fdo-mime versionator
-
-SUBDIR="v$(get_version_component_range 1-2)"
-
-HOMEPAGE="http://www.geda.seul.org"
-DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
-SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
-
-IUSE="gd threads"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-SLOT="0"
-
-DEPEND=">=x11-libs/gtk+-2.4
- >=dev-scheme/guile-1.6.3
- >=dev-libs/libstroke-0.5.1
- gd? ( >=media-libs/gd-2 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if has_version ">=dev-scheme/guile-1.8" ; then
- built_with_use "dev-scheme/guile" deprecated \
- || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
- fi
- if use gd ; then
- built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- # Skip the share sub-directory, we'll install prolog.ps manually
- sed -i \
- -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
- "${S}"/Makefile.in \
- || die "Patch failed"
-}
-
-src_compile() {
- local myconf="--disable-threads"
- use threads || myconf="--enable-threads=posix"
- econf \
- ${myconf} \
- --disable-dependency-tracking \
- --disable-rpath \
- --disable-update-mime-database \
- --with-x \
- $(use_enable gd) \
- || die "Configuration failed"
- emake || die "Compilation failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- insinto /usr/share/gEDA
- doins share/prolog.ps
-
- dodoc AUTHORS BUGS ChangeLog README
-}
-
-src_postinst() {
- fdo-mime_mime_database_update
-}
-
-src_postrm() {
- fdo-mime_mime_database_update
-}