summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf/ChangeLog10
-rw-r--r--sci-libs/netcdf/files/digest-netcdf-3.6.1-r13
-rw-r--r--sci-libs/netcdf/files/fPIC.1.patch24
-rw-r--r--sci-libs/netcdf/netcdf-3.6.1-r1.ebuild73
4 files changed, 109 insertions, 1 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index db727521803a..13cae1fb5c90 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/netcdf
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.31 2006/09/08 17:57:43 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.32 2006/10/24 12:31:31 markusle Exp $
+
+*netcdf-3.6.1-r1 (22 Oct 2006)
+
+ 22 Oct 2006; Markus Dittrich <markusle@gentoo.org> +files/fPIC.1.patch,
+ +netcdf-3.6.1-r1.ebuild:
+ Extended fPIC patch to C++ wrappers; otherwise packages that use
+ the netcdf library to generate shared objects create text
+ relocations (e.g. media-gfx/kst).
08 Sep 2006; Thomas Cort <tcort@gentoo.org> netcdf-3.6.1.ebuild:
Stable on alpha wrt Bug #82431.
diff --git a/sci-libs/netcdf/files/digest-netcdf-3.6.1-r1 b/sci-libs/netcdf/files/digest-netcdf-3.6.1-r1
new file mode 100644
index 000000000000..50e674c42d18
--- /dev/null
+++ b/sci-libs/netcdf/files/digest-netcdf-3.6.1-r1
@@ -0,0 +1,3 @@
+MD5 07a9db424337c5e4833fb84136e09a1e netcdf-3.6.1.tar.gz 883888
+RMD160 f46c3f65645169db60c8523eb28d498dfb6f7760 netcdf-3.6.1.tar.gz 883888
+SHA256 15c42a2c698c4e42ee17720701168711d86e97e97311223015d07853fb09249f netcdf-3.6.1.tar.gz 883888
diff --git a/sci-libs/netcdf/files/fPIC.1.patch b/sci-libs/netcdf/files/fPIC.1.patch
new file mode 100644
index 000000000000..cc4b4d8b7435
--- /dev/null
+++ b/sci-libs/netcdf/files/fPIC.1.patch
@@ -0,0 +1,24 @@
+diff -Naur netcdf-3.6.1/src/cxx/Makefile netcdf-3.6.1-new/src/cxx/Makefile
+--- netcdf-3.6.1/src/cxx/Makefile 2006-01-26 15:13:44.000000000 -0500
++++ netcdf-3.6.1-new/src/cxx/Makefile 2006-10-22 18:41:18.000000000 -0400
+@@ -11,6 +11,8 @@
+ nctst.cpp ncvalues.cpp ncvalues.h netcdf.cpp netcdfcpp.h \
+ netcdf.hh install-sh ref_nctst.cdl ref_nctst_64bit_offset.cdl
+
++CXXFLAGS += -fPIC
++
+ LIBRARY = libnetcdf_c++.a
+ lib_netcdf = ../libsrc/libnetcdf.a
+ ld_netcdf = -L../libsrc -lnetcdf
+diff -Naur netcdf-3.6.1/src/libsrc/Makefile netcdf-3.6.1-new/src/libsrc/Makefile
+--- netcdf-3.6.1/src/libsrc/Makefile 2005-02-17 11:15:11.000000000 -0500
++++ netcdf-3.6.1-new/src/libsrc/Makefile 2006-10-22 18:40:36.000000000 -0400
+@@ -14,6 +14,8 @@
+
+ MANUAL = netcdf.3
+
++CFLAGS += -fPIC
++
+ LIB_CSRCS = \
+ attr.c \
+ dim.c \
diff --git a/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild b/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..4b4bb12a938c
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1-r1.ebuild,v 1.1 2006/10/24 12:31:31 markusle Exp $
+
+inherit fortran eutils toolchain-funcs
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+HOMEPAGE="http://my.unidata.ucar.edu/content/software/netcdf/index.html"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+IUSE="fortran"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${P}/src"
+
+pkg_setup() {
+ if use fortran ; then
+ need_fortran "gfortran ifc g77"
+# fortran_pkg_setup
+ else
+ FORTRAN=""
+ fi
+}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/fPIC.1.patch || die "fPIC patch failed"
+}
+
+src_compile() {
+ local myconf
+
+ if use fortran ; then
+ if [ ${FORTRANC} == gfortran ] ; then
+ myconf="${myconf} CPPFLAGS=-DpgiFortran"
+ else
+ myconf="${myconf} CPPFLAGS=-Df2cFortran"
+ fi
+ fi
+
+ econf ${myconf} || die "econf failed"
+
+ make || die "make failed"
+}
+
+src_test() {
+ make test || die "make test failed"
+}
+
+src_install() {
+ dodir /usr/{lib,share} /usr/share/man/man3
+
+ einstall MANDIR=${D}usr/share/man || die "einstall failed"
+
+ if test -f ${D}usr/share/man/man3/netcdf.3f ; then
+ dodir /usr/share/man/man3f
+ mv ${D}usr/share/man/man3/netcdf.3f ${D}usr/share/man/man3f/ \
+ || die "Failed to move f77 man page"
+ dosed "s:NETCDF 3:NETCDF 3F:g" /usr/share/man/man3f/netcdf.3f \
+ || die "dosed failed"
+ if test -f ${D}usr/share/man/man3/netcdf.3f90 ; then
+ dodir /usr/share/man/man3f90
+ mv ${D}usr/share/man/man3/netcdf.3f90 ${D}usr/share/man/man3f90/ \
+ || die "Failed to move f90 man page"
+ fi
+ dodoc fortran/cfortran.doc || die "Failed to install fortran docs"
+ fi
+
+ dodoc COPYRIGHT README RELEASE_NOTES VERSION \
+ || die "Failed to install docs"
+}