summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog7
-rw-r--r--sci-libs/vtk/files/vtk-5.6.1-ffmpeg.patch6
-rw-r--r--sci-libs/vtk/files/vtk-5.6.1-gcc-46.patch29
-rw-r--r--sci-libs/vtk/vtk-5.6.0-r2.ebuild5
-rw-r--r--sci-libs/vtk/vtk-5.6.0-r3.ebuild5
-rw-r--r--sci-libs/vtk/vtk-5.6.1.ebuild5
6 files changed, 47 insertions, 10 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 43fcad59dcdd..f4a6072c7e2d 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.84 2011/04/17 13:50:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.85 2011/04/25 09:51:24 jlec Exp $
+
+ 25 Apr 2011; Justin Lecher <jlec@gentoo.org> vtk-5.6.0-r2.ebuild,
+ vtk-5.6.0-r3.ebuild, vtk-5.6.1.ebuild, files/vtk-5.6.1-ffmpeg.patch,
+ +files/vtk-5.6.1-gcc-46.patch:
+ Correct patch for USE=ffmpeg, 327957; Fix for gcc-4.6
17 Apr 2011; Justin Lecher <jlec@gentoo.org> vtk-5.6.0-r3.ebuild,
vtk-5.6.1.ebuild:
diff --git a/sci-libs/vtk/files/vtk-5.6.1-ffmpeg.patch b/sci-libs/vtk/files/vtk-5.6.1-ffmpeg.patch
index 0a347770b0e7..34ec528854a7 100644
--- a/sci-libs/vtk/files/vtk-5.6.1-ffmpeg.patch
+++ b/sci-libs/vtk/files/vtk-5.6.1-ffmpeg.patch
@@ -11,7 +11,7 @@ index ad691e3..32489d5 100644
extern "C" {
#ifdef HAS_OLD_HEADER
-# include <ffmpeg/avformat.h>
-+# include <libavcodec/avformat.h>
++# include <libavformat/avformat.h>
#else
# include <libavformat/avformat.h>
#endif
@@ -23,7 +23,7 @@ index 0bf4314..1c10a93 100644
extern "C" {
#ifdef HAS_OLD_HEADER
-# include <ffmpeg/avformat.h>
-+# include <libavcodec/avformat.h>
++# include <libavformat/avformat.h>
#else
# include <libavformat/avformat.h>
#endif
@@ -36,7 +36,7 @@ index 52673ef..ffbb78f 100644
extern "C" {
#ifdef VTK_FFMPEG_HAS_OLD_HEADER
-# include <ffmpeg/avformat.h>
-+# include <libavcodec/avformat.h>
++# include <libavformat/avformat.h>
#else
# include <libavformat/avformat.h>
#endif
diff --git a/sci-libs/vtk/files/vtk-5.6.1-gcc-46.patch b/sci-libs/vtk/files/vtk-5.6.1-gcc-46.patch
new file mode 100644
index 000000000000..263e24f69b3d
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.6.1-gcc-46.patch
@@ -0,0 +1,29 @@
+ Common/vtkPythonUtil.cxx | 2 ++
+ Utilities/vtkmetaio/metaUtils.cxx | 1 +
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/Common/vtkPythonUtil.cxx b/Common/vtkPythonUtil.cxx
+index 7bc7660..d218e0d 100644
+--- a/Common/vtkPythonUtil.cxx
++++ b/Common/vtkPythonUtil.cxx
+@@ -31,6 +31,8 @@
+ #include <vtkstd/map>
+ #include <vtkstd/string>
+
++#include <cstddef>
++
+ // Silent warning like
+ // "dereferencing type-punned pointer will break strict-aliasing rules"
+ // it happens because this kind of expression: (long *)&ptr
+diff --git a/Utilities/vtkmetaio/metaUtils.cxx b/Utilities/vtkmetaio/metaUtils.cxx
+index 08d3e8d..bbcc9ec 100644
+--- a/Utilities/vtkmetaio/metaUtils.cxx
++++ b/Utilities/vtkmetaio/metaUtils.cxx
+@@ -37,6 +37,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <string>
++#include <cstddef>
+
+ #if defined (__BORLANDC__) && (__BORLANDC__ >= 0x0580)
+ #include <mem.h>
diff --git a/sci-libs/vtk/vtk-5.6.0-r2.ebuild b/sci-libs/vtk/vtk-5.6.0-r2.ebuild
index 3cb3bb8b42c2..efa8356ec1ea 100644
--- a/sci-libs/vtk/vtk-5.6.0-r2.ebuild
+++ b/sci-libs/vtk/vtk-5.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0-r2.ebuild,v 1.9 2011/04/16 11:04:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0-r2.ebuild,v 1.10 2011/04/25 09:51:24 jlec Exp $
EAPI="3"
@@ -82,7 +82,8 @@ src_prepare() {
"${FILESDIR}"/${P}-boost-property_map.patch \
"${FILESDIR}"/${P}-libpng14.patch \
"${FILESDIR}"/${P}-R.patch \
- "${FILESDIR}"/${P}-odbc.patch
+ "${FILESDIR}"/${P}-odbc.patch \
+ "${FILESDIR}"/${PN}-5.6.1-gcc-46.patch
sed -e "s:@VTK_TCL_LIBRARY_DIR@:/usr/$(get_libdir):" \
-i Wrapping/Tcl/pkgIndex.tcl.in \
|| die "Failed to fix tcl pkgIndex file"
diff --git a/sci-libs/vtk/vtk-5.6.0-r3.ebuild b/sci-libs/vtk/vtk-5.6.0-r3.ebuild
index be42b40b5d4e..2f1863dae7ca 100644
--- a/sci-libs/vtk/vtk-5.6.0-r3.ebuild
+++ b/sci-libs/vtk/vtk-5.6.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0-r3.ebuild,v 1.2 2011/04/17 13:50:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0-r3.ebuild,v 1.3 2011/04/25 09:51:24 jlec Exp $
EAPI="3"
@@ -83,7 +83,8 @@ src_prepare() {
"${FILESDIR}"/${P}-libpng14.patch \
"${FILESDIR}"/${P}-R.patch \
"${FILESDIR}"/${P}-odbc.patch \
- "${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-ffmpeg.patch \
+ "${FILESDIR}"/${PN}-5.6.1-gcc-46.patch
# Fix sure buffer overflow on some processors as reported by Flameyes in #338819
sed -e "s:CHIPNAME_STRING_LENGTH (48 + 1):CHIPNAME_STRING_LENGTH (79 + 1):" \
-i Utilities/kwsys/SystemInformation.cxx \
diff --git a/sci-libs/vtk/vtk-5.6.1.ebuild b/sci-libs/vtk/vtk-5.6.1.ebuild
index 95457426d361..3dc8207b202b 100644
--- a/sci-libs/vtk/vtk-5.6.1.ebuild
+++ b/sci-libs/vtk/vtk-5.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.1.ebuild,v 1.2 2011/04/17 13:50:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.1.ebuild,v 1.3 2011/04/25 09:51:24 jlec Exp $
EAPI="3"
@@ -82,7 +82,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-5.6.0-libpng14.patch \
"${FILESDIR}"/${PN}-5.6.0-R.patch \
"${FILESDIR}"/${PN}-5.6.0-odbc.patch \
- "${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-ffmpeg.patch \
+ "${FILESDIR}"/${P}-gcc-46.patch
# Fix sure buffer overflow on some processors as reported by Flameyes in #338819
sed -e "s:CHIPNAME_STRING_LENGTH (48 + 1):CHIPNAME_STRING_LENGTH (79 + 1):" \