summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog8
-rw-r--r--sci-libs/scipy/files/scipy-0.7.2-optimize.patch54
-rw-r--r--sci-libs/scipy/scipy-0.7.2-r1.ebuild137
3 files changed, 198 insertions, 1 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index bfc0a9e1514a..8f032d7f01ed 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.50 2010/04/22 20:28:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.51 2010/05/18 17:25:31 bicatali Exp $
+
+*scipy-0.7.2-r1 (18 May 2010)
+
+ 18 May 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +scipy-0.7.2-r1.ebuild, +files/scipy-0.7.2-optimize.patch:
+ Applied a patch for the optimize module to work with sage, see bug #320135
*scipy-0.7.2 (22 Apr 2010)
diff --git a/sci-libs/scipy/files/scipy-0.7.2-optimize.patch b/sci-libs/scipy/files/scipy-0.7.2-optimize.patch
new file mode 100644
index 000000000000..4a3bb74012bd
--- /dev/null
+++ b/sci-libs/scipy/files/scipy-0.7.2-optimize.patch
@@ -0,0 +1,54 @@
+--- scipy/optimize/optimize.py.orig 2009-07-11 17:56:37.000000000 +1200
++++ scipy/optimize/optimize.py 2010-05-17 21:36:07.605336495 +1200
+@@ -41,6 +41,12 @@
+ m = asarray(m)
+ return numpy.minimum.reduce(m,axis)
+
++def is_array_scalar(x):
++ """Test whether `x` is either a scalar or an array scalar.
++
++ """
++ return len(atleast_1d(x) == 1)
++
+ abs = absolute
+ import __builtin__
+ pymin = __builtin__.min
+@@ -1177,13 +1183,12 @@
+
+ """
+ # Test bounds are of correct form
+- x1 = atleast_1d(x1)
+- x2 = atleast_1d(x2)
+- if len(x1) != 1 or len(x2) != 1:
+- raise ValueError, "Optimisation bounds must be scalars" \
+- " or length 1 arrays"
++
++ if not (is_array_scalar(x1) and is_array_scalar(x2)):
++ raise ValueError("Optimisation bounds must be scalars"
++ " or array scalars.")
+ if x1 > x2:
+- raise ValueError, "The lower bound exceeds the upper bound."
++ raise ValueError("The lower bound exceeds the upper bound.")
+
+ flag = 0
+ header = ' Func-count x f(x) Procedure'
+--- scipy/optimize/tests/test_optimize.py.orig 2009-07-11 17:56:37.000000000 +1200
++++ scipy/optimize/tests/test_optimize.py 2010-05-18 21:31:39.000000000 +1200
+@@ -159,10 +160,17 @@
+ assert abs(x - 1.5) < 1e-6
+ assert_raises(ValueError,
+ optimize.fminbound, lambda x: (x - 1.5)**2 - 0.8, 5, 1)
++
++ def test_fminbound_scalar(self):
+ assert_raises(ValueError,
+- optimize.fminbound, lambda x: (x - 1.5)**2 - 0.8,
++ optimize.fminbound, lambda x: (x - 1.5)**2 - 0.8,
+ np.zeros(2), 1)
+
++ assert_almost_equal(
++ optimize.fminbound(lambda x: (x - 1.5)**2 - 0.8, 1, np.array(5)),
++ 1.5)
++
++
+ class TestTnc(TestCase):
+ """TNC non-linear optimization.
diff --git a/sci-libs/scipy/scipy-0.7.2-r1.ebuild b/sci-libs/scipy/scipy-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..017ccd4765d9
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.7.2-r1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.7.2-r1.ebuild,v 1.1 2010/05/18 17:25:31 bicatali Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils flag-o-matic toolchain-funcs versionator
+
+SP="${PN}-$(get_version_component_range 1-2)"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? (
+ http://docs.scipy.org/doc/${SP}.x/${PN}-html.zip -> ${SP}-html.zip
+ http://docs.scipy.org/doc/${SP}.x/${PN}-ref.pdf -> ${SP}-ref.pdf
+ )"
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
+
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="doc umfpack"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND=">=dev-python/numpy-1.2
+ virtual/cblas
+ virtual/lapack
+ umfpack? ( sci-libs/umfpack )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ umfpack? ( dev-lang/swig )
+ doc? ( app-arch/unzip )"
+# test? ( dev-python/nose )
+
+RDEPEND="${CDEPEND}
+ dev-python/imaging"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+# buggy tests
+RESTRICT="test"
+
+DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
+
+pkg_setup() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use umfpack && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC=$(tc-getFC)
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77=$(tc-getFC)
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${SP}-html.zip -d html || die
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.0_beta1-implicit.patch
+ epatch "${FILESDIR}"/${PN}-0.6.0-stsci.patch
+ epatch "${FILESDIR}"/${PN}-0.7.1-weave.patch
+ epatch "${FILESDIR}"/${PN}-0.7.2-optimize.patch
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat > site.cfg <<-EOF
+ [atlas]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas blas lapack| sed -e \
+ 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
+ atlas_libs = $(pkg-config --libs-only-l \
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ lapack_libs = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ [blas_opt]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):${libdir}
+ libraries = $(pkg-config --libs-only-l \
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ [lapack_opt]
+ library_dirs = $(pkg-config --libs-only-L \
+ lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):${libdir}
+ libraries = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ EOF
+}
+
+src_compile() {
+ [[ -n ${FFLAGS} ]] && FFLAGS="${FFLAGS} -fPIC"
+ distutils_src_compile ${SCIPY_FCONFIG}
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
+ --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} || die "install test failed"
+ pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
+ PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" 2>&1 | tee test.log
+ grep -q ^ERROR test.log && die "test failed"
+ popd > /dev/null
+ rm -fr test-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install ${SCIPY_FCONFIG}
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${WORKDIR}"/html || die
+ doins "${DISTDIR}"/${SP}*pdf || die
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer if you don't like the default one. Ex:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}