summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libcore')
-rw-r--r--sci-libs/libcore/ChangeLog5
-rw-r--r--sci-libs/libcore/libcore-1.7.ebuild21
2 files changed, 13 insertions, 13 deletions
diff --git a/sci-libs/libcore/ChangeLog b/sci-libs/libcore/ChangeLog
index 7d556ce20fca..3820e4621049 100644
--- a/sci-libs/libcore/ChangeLog
+++ b/sci-libs/libcore/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/libcore
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/ChangeLog,v 1.3 2008/06/29 08:08:55 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/ChangeLog,v 1.4 2008/09/03 09:32:37 bicatali Exp $
+
+ 03 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org> libcore-1.7.ebuild:
+ Fixed virtual/tetex, tested on am64 and some cleaning
29 Jun 2008; Torsten Veller <tove@gentoo.org> libcore-1.7.ebuild:
Add missing die: || "..." -> || die "..."
diff --git a/sci-libs/libcore/libcore-1.7.ebuild b/sci-libs/libcore/libcore-1.7.ebuild
index fca7ad548627..8fa10e0cd929 100644
--- a/sci-libs/libcore/libcore-1.7.ebuild
+++ b/sci-libs/libcore/libcore-1.7.ebuild
@@ -1,36 +1,34 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/libcore-1.7.ebuild,v 1.3 2008/06/29 08:08:55 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcore/libcore-1.7.ebuild,v 1.4 2008/09/03 09:32:37 bicatali Exp $
inherit eutils toolchain-funcs
-DESCRIPTION="The main goal of the CORE project is to address the issues of
-robust numerical and geometric computation."
+DESCRIPTION="Robust numerical and geometric computation library"
HOMEPAGE="http://www.cs.nyu.edu/exact/core_pages/"
MYP="${PN/lib}"
SRC_URI="http://cs.nyu.edu/exact/core/download/prerelease/${MYP}_v${PV}x_std.tgz"
LICENSE="QPL-1.0"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc"
DEPEND="dev-libs/gmp
- doc? ( virtual/tetex ) "
-RDEPEND="virtual/libc"
+ doc? ( virtual/latex-base ) "
+RDEPEND=""
S="${WORKDIR}/${MYP}_v${PV}x"
src_unpack(){
- unpack "${A}"
+ unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/${P}.patch || die "Unable to patch sources"
+ epatch "${FILESDIR}"/${P}.patch
}
src_compile(){
- cd "${S}"
- emake CXX=$(tc-getCXX) corelib || die "Unable to create corelib"
- emake CXX=$(tc-getCXX) corex || die "Unable to create corex"
+ emake CXX="$(tc-getCXX)" corelib || die "Unable to create corelib"
+ emake CXX="$(tc-getCXX)" corex || die "Unable to create corex"
if use doc; then
cd "${S}/doc"
emake all || die "Unable to create doc"
@@ -38,7 +36,6 @@ src_compile(){
}
src_install(){
- cd "${S}"
dolib lib/*.a lib/*.so || die "Unable to find libraries"
for i in $(find "${D}/usr/lib/" -name "*so" | sed "s:${D}::g"); do
dosym $i $i.1 && dosym $i $i.1.0.0 || die "Unable to sym $i"