summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gts')
-rw-r--r--sci-libs/gts/ChangeLog6
-rw-r--r--sci-libs/gts/files/gts-20111025-autotools.patch16
-rw-r--r--sci-libs/gts/gts-20111025.ebuild18
3 files changed, 33 insertions, 7 deletions
diff --git a/sci-libs/gts/ChangeLog b/sci-libs/gts/ChangeLog
index 83129fe07461..59caa3522780 100644
--- a/sci-libs/gts/ChangeLog
+++ b/sci-libs/gts/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gts
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.21 2012/01/20 19:17:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.22 2012/01/21 15:11:51 jlec Exp $
+
+ 21 Jan 2012; Justin Lecher <jlec@gentoo.org> gts-20111025.ebuild,
+ files/gts-20111025-autotools.patch:
+ Drop doc installation as doc generation is broken, #399613
*gts-20111025 (20 Jan 2012)
diff --git a/sci-libs/gts/files/gts-20111025-autotools.patch b/sci-libs/gts/files/gts-20111025-autotools.patch
index 9f0148b07b35..7660f789f7a7 100644
--- a/sci-libs/gts/files/gts-20111025-autotools.patch
+++ b/sci-libs/gts/files/gts-20111025-autotools.patch
@@ -26,3 +26,19 @@
CLEANFILES = $(BUILT_SOURCES)
+ gts-snapshot-111025/doc/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/gts-snapshot-111025/doc/Makefile.am b/gts-snapshot-111025/doc/Makefile.am
+index ea9a468..cd5a606 100644
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -9,7 +9,7 @@ DOC_MODULE=gts
+ DOC_MAIN_SGML_FILE=gts-docs.sgml
+
+ # The directory containing the source code (if it contains documentation).
+-DOC_SOURCE_DIR=../src
++DOC_SOURCE_DIR=$(top_srcdir)/src
+
+ TARGET_DIR=html/$(DOC_MODULE)
+
diff --git a/sci-libs/gts/gts-20111025.ebuild b/sci-libs/gts/gts-20111025.ebuild
index 18c4d5de8bb5..6a6ebcfbf062 100644
--- a/sci-libs/gts/gts-20111025.ebuild
+++ b/sci-libs/gts/gts-20111025.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/gts-20111025.ebuild,v 1.1 2012/01/20 19:17:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/gts-20111025.ebuild,v 1.2 2012/01/21 15:11:51 jlec Exp $
EAPI=4
-AUTOTOOLS_AUTORECONF=yes
-inherit fortran-2 autotools-utils
+
+inherit autotools-utils fortran-2
DESCRIPTION="GNU Triangulated Surface Library"
LICENSE="LGPL-2"
@@ -14,7 +14,7 @@ SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc examples static-libs test"
+IUSE="examples static-libs test"
RDEPEND="virtual/fortran
dev-libs/glib:2
@@ -26,9 +26,15 @@ DEPEND="${RDEPEND}
# buggy
RESTRICT=test
-PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
S="${WORKDIR}"/${P/-20/-snapshot-}
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
+src_compile() {
+ autotools-utils_src_compile
+# use doc && autotools-utils_src_compile -j1 -C doc scan sgml html
+}
+
src_test() {
chmod +x test/*/*.sh
cd ${AUTOTOOLS_BUILD_DIR}/test/boolean
@@ -43,7 +49,7 @@ src_install() {
mv "${ED}"/usr/bin/{,gts-}split || die
mv "${ED}"/usr/bin/{,gts-}merge || die
- use doc && dohtml doc/html/*
+# use doc && dohtml doc/html/*
if use examples; then
insinto /usr/share/doc/${PF}/examples