summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cgcode/cgcode-1.0.ebuild')
-rw-r--r--sci-libs/cgcode/cgcode-1.0.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/sci-libs/cgcode/cgcode-1.0.ebuild b/sci-libs/cgcode/cgcode-1.0.ebuild
index 6e39ed7ea937..df42a7418186 100644
--- a/sci-libs/cgcode/cgcode-1.0.ebuild
+++ b/sci-libs/cgcode/cgcode-1.0.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cgcode/cgcode-1.0.ebuild,v 1.2 2010/11/10 14:16:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cgcode/cgcode-1.0.ebuild,v 1.3 2010/12/16 14:29:57 jlec Exp $
EAPI="3"
-inherit eutils fortran
-
-FORTRNC="ifort gfortran"
+inherit eutils toolchain-funcs
DESCRIPTION="Conjugate gradient Codes for large sparse linear systems"
HOMEPAGE="http://fetk.org/codes/cgcode/index.html"
@@ -26,7 +24,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PV}-gentoo.patch
cat >> make.inc <<- EOF
- F77 = ${FORTRANC}
+ F77 = $(tc-getFC)
FFLAGS = ${FFLAGS}
BLASLIBS = $(pkg-config --libs blas)
EOF