summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/tinker/ChangeLog8
-rw-r--r--sci-chemistry/tinker/files/5.1.09-Makefile.patch13
-rw-r--r--sci-chemistry/tinker/tinker-5.1.09.ebuild (renamed from sci-chemistry/tinker/tinker-5.1.08.ebuild)17
3 files changed, 33 insertions, 5 deletions
diff --git a/sci-chemistry/tinker/ChangeLog b/sci-chemistry/tinker/ChangeLog
index 53be824fad40..cfc2350b9fe3 100644
--- a/sci-chemistry/tinker/ChangeLog
+++ b/sci-chemistry/tinker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/tinker
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.24 2010/10/03 08:31:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.25 2010/10/03 10:49:15 jlec Exp $
+
+*tinker-5.1.09 (03 Oct 2010)
+
+ 03 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/5.1.09-Makefile.patch,
+ -tinker-5.1.08.ebuild, +tinker-5.1.09.ebuild:
+ Version bump, fixes 335197 & 337074
03 Oct 2010; Justin Lecher <jlec@gentoo.org> tinker-5.1.08.ebuild,
tinker-6.0.ebuild:
diff --git a/sci-chemistry/tinker/files/5.1.09-Makefile.patch b/sci-chemistry/tinker/files/5.1.09-Makefile.patch
new file mode 100644
index 000000000000..68a095add706
--- /dev/null
+++ b/sci-chemistry/tinker/files/5.1.09-Makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/make/Makefile b/make/Makefile
+index 221ab45..7634474 100644
+--- a/make/Makefile
++++ b/make/Makefile
+@@ -607,7 +607,7 @@ clean:
+ listing:
+ cat *.i *.f > tinker.txt
+
+-rename:
++rename: ${EXEFILES}
+ mv alchemy.x $(BINDIR)/alchemy
+ mv analyze.x $(BINDIR)/analyze
+ mv anneal.x $(BINDIR)/anneal
diff --git a/sci-chemistry/tinker/tinker-5.1.08.ebuild b/sci-chemistry/tinker/tinker-5.1.09.ebuild
index 14fd42a76b65..f3796752ac48 100644
--- a/sci-chemistry/tinker/tinker-5.1.08.ebuild
+++ b/sci-chemistry/tinker/tinker-5.1.09.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-5.1.08.ebuild,v 1.3 2010/10/03 08:31:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-5.1.09.ebuild,v 1.1 2010/10/03 10:49:16 jlec Exp $
EAPI="2"
FORTRAN="gfortran ifc"
-inherit fortran java-pkg-opt-2 toolchain-funcs
+inherit eutils fortran java-pkg-opt-2 toolchain-funcs
DESCRIPTION="Molecular modeling package that includes force fields, such as AMBER and CHARMM"
HOMEPAGE="http://dasher.wustl.edu/tinker/"
@@ -30,12 +30,18 @@ pkg_setup() {
fortran_pkg_setup
java-pkg-opt-2_pkg_setup
}
+
+src_prepare() {
+ cd ..
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+}
+
src_compile() {
local javalib=
for i in $(java-config -g LDPATH | sed 's|:| |g'); do
[[ -f ${i}/libjvm.so ]] && javalib=${i}
done
- emake \
+ emake -e \
-f ../make/Makefile \
F77="${FORTRANC}" \
CC="$(tc-getCC) -c" \
@@ -44,13 +50,15 @@ src_compile() {
LINKFLAGS="${LDFLAGS} -Wl,-rpath ${javalib}" \
INCLUDEDIR="$(java-pkg_get-jni-cflags) -I${EPREFIX}/usr/include" \
LIBS="$(pkg-config --libs apbs) -lmaloc -L${javalib} -ljvm" \
- || die
+ all || die
mkdir "${S}"/../bin || die
+
emake \
-f ../make/Makefile \
BINDIR="${S}"/../bin \
rename || die
}
+
src_test() {
cd "${WORKDIR}"/tinker/test/
for test in *.run; do
@@ -67,6 +75,7 @@ src_install() {
dodoc \
"${WORKDIR}"/${PN}/doc/{*.txt,announce/release-*,*.pdf,0README} || die
+
if use examples; then
insinto /usr/share/${P}
doins -r "${WORKDIR}"/${PN}/example || die