summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gsim/ChangeLog8
-rw-r--r--sci-chemistry/gsim/files/gsim-21.3-build.conf.patch49
-rw-r--r--sci-chemistry/gsim/gsim-21.3.ebuild67
3 files changed, 123 insertions, 1 deletions
diff --git a/sci-chemistry/gsim/ChangeLog b/sci-chemistry/gsim/ChangeLog
index ea292148eab6..470632c165ae 100644
--- a/sci-chemistry/gsim/ChangeLog
+++ b/sci-chemistry/gsim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/gsim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gsim/ChangeLog,v 1.10 2013/06/19 04:03:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gsim/ChangeLog,v 1.11 2013/11/09 11:23:26 jlec Exp $
+
+*gsim-21.3 (09 Nov 2013)
+
+ 09 Nov 2013; Justin Lecher <jlec@gentoo.org> +gsim-21.3.ebuild,
+ +files/gsim-21.3-build.conf.patch:
+ Vesion Bump
19 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Changed herd to sci-chemistry
diff --git a/sci-chemistry/gsim/files/gsim-21.3-build.conf.patch b/sci-chemistry/gsim/files/gsim-21.3-build.conf.patch
new file mode 100644
index 000000000000..da7d7b7b4457
--- /dev/null
+++ b/sci-chemistry/gsim/files/gsim-21.3-build.conf.patch
@@ -0,0 +1,49 @@
+ gsim.pro | 23 ++++++++++++++---------
+ 1 file changed, 14 insertions(+), 9 deletions(-)
+
+diff --git a/gsim.pro b/gsim.pro
+index f88dc8a..579a91c 100755
+--- a/gsim.pro
++++ b/gsim.pro
+@@ -10,27 +10,32 @@
+
+ #Uncomment next line if you want to use EMF output
+ #EMF output requires libEMF or Wine on X11 systems and MAC(?)
+-CONFIG+=use_emf
++#CONFIG+=use_emf
+
+ #DO NOT UNCOMMENT NEXT LINE. The scripting possibilty won't work at the moment
+ #CONFIG+=use_script
+
+ # Change directories locations for libcmatrix, MinUIT and muParser libraries
+-unix:INCLUDEPATH += /home/dch0ph/libcmatrixR3nosse/include \
+- /home/dch1vz/Minuit2/include \
+- /home/dch1vz/muparser/include
++#unix:INCLUDEPATH += /home/dch0ph/libcmatrixR3nosse/include \
++# /home/dch1vz/Minuit2/include \
++# /home/dch1vz/muparser/include
+
+ win32:INCLUDEPATH += "C:\gsim\libcmatrixR3_qt4\include" "C:\gsim\Minuit2_qt4\include" "C:\gsim\muparser_qt4\include"
+
+-unix:LIBS += -lcmatrix -L/home/dch0ph/libcmatrixR3nosse/lib -lMinuit2Base -L/home/dch1vz/Minuit2/lib -L/home/dch1vz/muparser/lib -lmuparser
++#unix:LIBS += -lcmatrix -L/home/dch0ph/libcmatrixR3nosse/lib -lMinuit2Base -L/home/dch1vz/Minuit2/lib -L/home/dch1vz/muparser/lib -lmuparser
+
+ win32:LIBS += -lcmatrix -L"C:\gsim\libcmatrixR3_qt4\lib" -lMinuit2 -L"C:\gsim\Minuit2_qt4\lib" -L"C:\gsim\muparser_qt4\lib" -lmuparser
+
+ #Change directories location for libEMF (if used)
+-use_emf {
+- DEFINES+=USE_EMF_OUTPUT
+- unix:LIBS +=-lEMF -L/usr/include/libEmf
+- win32:LIBS +=-lgdi32
++#use_emf {
++# DEFINES+=USE_EMF_OUTPUT
++# unix:LIBS +=-lEMF -L/usr/include/libEmf
++# win32:LIBS +=-lgdi32
++#}
++
++GSIM_ROOT = .
++!include( $$GSIM_ROOT/build.conf ) {
++ message( "You need a build.conf file with local settings!" )
+ }
+
+ #################################################################################################
diff --git a/sci-chemistry/gsim/gsim-21.3.ebuild b/sci-chemistry/gsim/gsim-21.3.ebuild
new file mode 100644
index 000000000000..37c9e6a04c6a
--- /dev/null
+++ b/sci-chemistry/gsim/gsim-21.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gsim/gsim-21.3.ebuild,v 1.1 2013/11/09 11:23:26 jlec Exp $
+
+EAPI=5
+
+inherit eutils qt4-r2 toolchain-funcs
+
+DESCRIPTION="Programm for visualisation and processing of experimental and simulated NMR spectra"
+HOMEPAGE="http://sourceforge.net/projects/gsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emf opengl"
+
+RDEPEND="
+ dev-cpp/muParser
+ media-libs/freetype
+ sci-libs/libcmatrix
+ sci-libs/minuit
+ virtual/blas
+ dev-qt/qtsvg:4
+ emf? ( media-libs/libemf )
+ opengl? ( dev-qt/qtopengl:4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-build.conf.patch )
+DOCS="release.txt README_GSIM.* quickstart.* changes.log programming.*"
+
+src_prepare() {
+ edos2unix ${PN}.pro
+
+ qt4-r2_src_prepare
+
+ cat >> build.conf <<- EOF
+ INCLUDEPATH += "${EPREFIX}/usr/include/libcmatrixR3/" \
+ "${EPREFIX}/usr/include/Minuit2" \
+ "${EPREFIX}/usr/include"
+ LIBS += -lcmatrix -lMinuit2 -lmuparser $($(tc-getPKG_CONFIG) --libs cblas)
+ EOF
+
+ use opengl && echo "CONFIG+=use_opengl" >> build.conf
+
+ if use emf; then
+ cat >> build.conf <<- EOF
+ CONFIG+=use_emf
+ DEFINES+=USE_EMF_OUTPUT
+ LIBS += -L\"${EPREFIX}/usr/include/libEMF\" -lEMF
+ EOF
+ fi
+ sed \
+ -e "s:quickstart.pdf:../share/doc/${PF}/quickstart.pdf:g" \
+ -e "s:README_GSIM.pdf:../share/doc/${PF}/README_GSIM.pdf:g" \
+ -i mainform.h || die
+}
+
+src_install() {
+ qt4-r2_src_install
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r images ${PN}.ico
+ insinto /usr/share/${PN}/ui
+ doins *.ui
+}