summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mpqc/mpqc-2.2.3.ebuild')
-rw-r--r--sci-chemistry/mpqc/mpqc-2.2.3.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-chemistry/mpqc/mpqc-2.2.3.ebuild b/sci-chemistry/mpqc/mpqc-2.2.3.ebuild
index 7eec6207368b..05e16bab23ee 100644
--- a/sci-chemistry/mpqc/mpqc-2.2.3.ebuild
+++ b/sci-chemistry/mpqc/mpqc-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/mpqc-2.2.3.ebuild,v 1.2 2005/05/24 22:01:20 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/mpqc-2.2.3.ebuild,v 1.3 2005/06/11 16:24:38 corsair Exp $
inherit fortran
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/mpqc/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
# Should work on x86, amd64 and ppc, at least
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc X threads"
DEPEND="sys-devel/flex
@@ -28,6 +28,12 @@ src_compile() {
use X \
&& myconf="${myconf} --x-includes=/usr/X11R6/include \
--x-libraries=/usr/X11R6/lib"
+
+ # only shared will work on ppc64 - bug #62124
+ if use ppc64; then
+ myconf="${myconf} --enable-shared"
+ fi
+
./configure \
$(use_enable threads) \
${myconf} || die "configure failed"