summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild')
-rw-r--r--sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild b/sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild
new file mode 100644
index 000000000000..36899f337d12
--- /dev/null
+++ b/sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cluster/cluster-1.3.081231-r1.ebuild,v 1.1 2012/06/07 15:03:26 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Build lists of collections of interacting items"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/index.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${PN}.${PV}.src.tgz"
+
+SLOT="0"
+LICENSE="richardson"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${PN}1.3src
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-includes.patch
+ tc-export CXX
+}
+
+src_install() {
+ newbin ${PN} molprobity-${PN}
+ dodoc README.cluster
+}