summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ccp4-apps')
-rw-r--r--sci-chemistry/ccp4-apps/ChangeLog6
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild7
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild5
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild5
4 files changed, 15 insertions, 8 deletions
diff --git a/sci-chemistry/ccp4-apps/ChangeLog b/sci-chemistry/ccp4-apps/ChangeLog
index 837199428582..1f1f88c2804f 100644
--- a/sci-chemistry/ccp4-apps/ChangeLog
+++ b/sci-chemistry/ccp4-apps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/ccp4-apps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.25 2011/03/14 17:06:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.26 2011/06/21 08:41:27 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> ccp4-apps-6.1.3-r7.ebuild,
+ ccp4-apps-6.1.3-r8.ebuild, ccp4-apps-6.1.3-r9.ebuild:
+ Added fortran-2.eclass support
14 Mar 2011; Justin Lecher <jlec@gentoo.org> +files/6.1.3-lapack.patch,
ccp4-apps-6.1.3-r9.ebuild:
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild
index 579bdc4b4401..ed78231d8d65 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild,v 1.2 2011/03/02 17:53:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild,v 1.3 2011/06/21 08:41:27 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit autotools eutils flag-o-matic gnuconfig python toolchain-funcs
+inherit autotools eutils fortran-2 flag-o-matic gnuconfig python toolchain-funcs
MY_P="${PN/-apps}-${PV}"
@@ -103,6 +103,7 @@ PDEPEND="${SCIAPPS}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
+ fortran-2_pkg_setup
python_set_active_version 2
}
@@ -133,7 +134,7 @@ src_prepare() {
# libraries come from sci-libs/ccp4-libs
ccp_patch "${FILESDIR}"/${PV}-dont-build-libs.patch
- # coreutils installs a binary called truncate
+ # coreutils fortran-2 installs a binary called truncate
# ccp_patch "${FILESDIR}"/${PV}-rename-truncate.patch
# mv ./doc/truncate.doc ./doc/ftruncate.doc || die
# mv ./html/truncate.html ./html/ftruncate.html || die
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild
index 0bef8dc77473..26a2ff648235 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild,v 1.4 2011/03/04 17:02:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild,v 1.5 2011/06/21 08:41:27 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit autotools eutils flag-o-matic gnuconfig python toolchain-funcs
+inherit autotools eutils fortran-2 flag-o-matic gnuconfig python toolchain-funcs
MY_P="${PN/-apps}-${PV}"
@@ -103,6 +103,7 @@ PDEPEND="${SCIAPPS}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
+ fortran-2_pkg_setup
python_set_active_version 2
}
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild
index 520ad814532e..be70068c6fae 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild,v 1.2 2011/03/14 17:06:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild,v 1.3 2011/06/21 08:41:27 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit autotools eutils flag-o-matic gnuconfig python toolchain-funcs
+inherit autotools eutils fortran-2 flag-o-matic gnuconfig python toolchain-funcs
MY_P="${PN/-apps}-${PV}"
@@ -103,6 +103,7 @@ PDEPEND="${SCIAPPS}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
+ fortran-2_pkg_setup
python_set_active_version 2
}