summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/orpie/orpie-1.4.1.ebuild')
-rw-r--r--sci-calculators/orpie/orpie-1.4.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-calculators/orpie/orpie-1.4.1.ebuild b/sci-calculators/orpie/orpie-1.4.1.ebuild
new file mode 100644
index 000000000000..857cacd9fcec
--- /dev/null
+++ b/sci-calculators/orpie/orpie-1.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/orpie-1.4.1.ebuild,v 1.1 2005/02/03 01:35:20 ribosome Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A fullscreen RPN calculator for the console"
+HOMEPAGE="http://www.eecs.umich.edu/~pelzlpj/orpie/"
+SRC_URI="http://www.eecs.umich.edu/~pelzlpj/orpie/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/ocaml
+ sci-libs/gsl
+ sys-libs/ncurses"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D}
+ dodoc doc/TODO
+ insinto /usr/share/doc/${PF}
+ doins doc/manual.pdf
+ doins doc/manual.html
+}