summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'perl-core/Module-Build/Module-Build-0.28-r1.ebuild')
-rw-r--r--perl-core/Module-Build/Module-Build-0.28-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/perl-core/Module-Build/Module-Build-0.28-r1.ebuild b/perl-core/Module-Build/Module-Build-0.28-r1.ebuild
new file mode 100644
index 000000000000..8ae9ebdcd395
--- /dev/null
+++ b/perl-core/Module-Build/Module-Build-0.28-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Module-Build/Module-Build-0.28-r1.ebuild,v 1.1 2008/11/02 07:27:45 tove Exp $
+
+inherit perl-module
+
+MY_PV=${PV/26.11/2611}
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc64 s390 sh sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=virtual/perl-ExtUtils-CBuilder-0.15
+ >=virtual/perl-ExtUtils-ParseXS-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=virtual/perl-Archive-Tar-1.09"
+
+SRC_TEST="do"