summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zope-session/zope-session-3.9.3.ebuild')
-rw-r--r--net-zope/zope-session/zope-session-3.9.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-zope/zope-session/zope-session-3.9.3.ebuild b/net-zope/zope-session/zope-session-3.9.3.ebuild
new file mode 100644
index 000000000000..af3dea371e4d
--- /dev/null
+++ b/net-zope/zope-session/zope-session-3.9.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-session/zope-session-3.9.3.ebuild,v 1.1 2010/09/25 18:44:58 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Client identification and sessions for Zope"
+HOMEPAGE="http://pypi.python.org/pypi/zope.session"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/zodb
+ net-zope/zope-component
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-minmax
+ net-zope/zope-publisher
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"