summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mozilla/mozilla-1.4-r3.ebuild')
-rw-r--r--net-www/mozilla/mozilla-1.4-r3.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/net-www/mozilla/mozilla-1.4-r3.ebuild b/net-www/mozilla/mozilla-1.4-r3.ebuild
index b4c4a0676064..1d21f7cd4acc 100644
--- a/net-www/mozilla/mozilla-1.4-r3.ebuild
+++ b/net-www/mozilla/mozilla-1.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.4-r3.ebuild,v 1.8 2003/09/06 01:54:09 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.4-r3.ebuild,v 1.9 2003/09/11 17:14:46 lu_zero Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome debug"
# Internal USE flags that I do not really want to advertise ...
@@ -9,14 +9,6 @@ IUSE="${IUSE} moznoirc moznomail moznocompose moznoxft"
inherit flag-o-matic gcc eutils nsplugins
-# Crashes on start when compiled with -fomit-frame-pointer
-filter-flags "-fomit-frame-pointer"
-filter-flags -ffast-math
-append-flags -s -fforce-addr
-
-# Sparc support ...
-replace-sparc64-flags
-
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
# still having issues with optimizations, or with it not filtering bad
@@ -38,6 +30,22 @@ replace-sparc64-flags
#
# <azarah@gentoo.org> (13 Oct 2002)
strip-flags
+#
+# Crashes on start when compiled with -fomit-frame-pointer
+filter-flags "-fomit-frame-pointer"
+filter-flags -ffast-math
+append-flags -s -fforce-addr
+
+# Sparc support ...
+replace-sparc64-flags
+
+#fix to avoid gcc-3.3.x micompilation issues.
+if [ "`use ppc`" -a "$(gcc-major-version)" -eq "3" -a "$(gcc-minor-version)" -eq "3" ]
+then
+
+append-flags -fno-strict-aliasing
+
+fi
# We set -O in ./configure to -O1, as -O2 cause crashes on startup ...
# (bug #13287)
@@ -56,7 +64,7 @@ S="${WORKDIR}/mozilla"
DESCRIPTION="The Mozilla Web Browser"
SRC_URI="ftp://ftp.mozilla.org/pub/mozilla/releases/${PN}${MY_PV2}/src/${PN}-source-${MY_PV2}.tar.bz2
crypt? ( http://downloads.mozdev.org/enigmail/src/enigmail-${EMVER}.tar.gz
- http://enigmail.mozdev.org/dload/src/ipc-${IPCVER}.tar.gz )"
+ http://enigmail.mozdev.org/dload/src/ipc-${IPCVER}.tar.gz )"
# mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
HOMEPAGE="http://www.mozilla.org"