summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/ChangeLog6
-rw-r--r--net-wireless/hostapd/hostapd-0.4.8.ebuild6
-rw-r--r--net-wireless/hostapd/hostapd-0.5.0-r1.ebuild6
-rw-r--r--net-wireless/hostapd/hostapd-0.5.0.ebuild6
-rw-r--r--net-wireless/hostapd/hostapd-0.5.1.ebuild6
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog7
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild6
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild6
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild6
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild6
10 files changed, 35 insertions, 26 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index c3e8e0c9f5b4..b413e283b58f 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.57 2006/02/19 21:54:03 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.58 2006/02/27 21:45:59 brix Exp $
+
+ 27 Feb 2006; Henrik Brix Andersen <brix@gentoo.org> hostapd-0.4.8.ebuild,
+ hostapd-0.5.0.ebuild, hostapd-0.5.0-r1.ebuild, hostapd-0.5.1.ebuild:
+ Fix madwifi compilation with ROOT != "/".
19 Feb 2006; Michael Hanselmann <hansmi@gentoo.org>
hostapd-0.4.7-r2.ebuild:
diff --git a/net-wireless/hostapd/hostapd-0.4.8.ebuild b/net-wireless/hostapd/hostapd-0.4.8.ebuild
index 5a2584aefa3e..12424742fddd 100644
--- a/net-wireless/hostapd/hostapd-0.4.8.ebuild
+++ b/net-wireless/hostapd/hostapd-0.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.4.8.ebuild,v 1.1 2006/02/14 12:09:44 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.4.8.ebuild,v 1.2 2006/02/27 21:45:59 brix Exp $
inherit toolchain-funcs
@@ -59,8 +59,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}
diff --git a/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild b/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild
index 8d0c7c3a2698..271743354596 100644
--- a/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild
+++ b/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0-r1.ebuild,v 1.3 2006/02/27 21:45:59 brix Exp $
inherit toolchain-funcs
@@ -60,8 +60,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}
diff --git a/net-wireless/hostapd/hostapd-0.5.0.ebuild b/net-wireless/hostapd/hostapd-0.5.0.ebuild
index 62bcdf3789c3..53b126067cae 100644
--- a/net-wireless/hostapd/hostapd-0.5.0.ebuild
+++ b/net-wireless/hostapd/hostapd-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.0.ebuild,v 1.3 2006/02/27 21:45:59 brix Exp $
inherit toolchain-funcs
@@ -60,8 +60,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}
diff --git a/net-wireless/hostapd/hostapd-0.5.1.ebuild b/net-wireless/hostapd/hostapd-0.5.1.ebuild
index 0932def53603..fb3c6404e424 100644
--- a/net-wireless/hostapd/hostapd-0.5.1.ebuild
+++ b/net-wireless/hostapd/hostapd-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.1.ebuild,v 1.2 2006/02/16 10:28:31 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.1.ebuild,v 1.3 2006/02/27 21:45:59 brix Exp $
inherit toolchain-funcs
@@ -60,8 +60,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index ecd7f24393d4..af5284eb1d32 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.51 2006/02/14 12:11:55 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.52 2006/02/27 21:49:53 brix Exp $
+
+ 27 Feb 2006; Henrik Brix Andersen <brix@gentoo.org>
+ wpa_supplicant-0.4.7-r1.ebuild, wpa_supplicant-0.4.8.ebuild,
+ wpa_supplicant-0.5.0-r1.ebuild, wpa_supplicant-0.5.1.ebuild:
+ Fix madwifi compilation with ROOT != "/".
*wpa_supplicant-0.4.8 (14 Feb 2006)
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild
index 48293bd1bde4..948f39ccd120 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild,v 1.2 2006/01/17 20:07:22 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.7-r1.ebuild,v 1.3 2006/02/27 21:49:53 brix Exp $
inherit eutils toolchain-funcs
@@ -77,8 +77,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild
index a52b5d0c0834..f61958e612a1 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild,v 1.1 2006/02/14 12:11:55 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.4.8.ebuild,v 1.2 2006/02/27 21:49:53 brix Exp $
inherit eutils toolchain-funcs
@@ -77,8 +77,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild
index 799ccaf90c6e..c8ec8be4a207 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild,v 1.2 2006/01/17 20:07:22 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.0-r1.ebuild,v 1.3 2006/02/27 21:49:53 brix Exp $
inherit eutils toolchain-funcs
@@ -78,8 +78,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild
index 197a0f4de862..637f3f49d63a 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild,v 1.2 2006/02/06 13:45:56 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.1.ebuild,v 1.3 2006/02/27 21:49:53 brix Exp $
inherit eutils toolchain-funcs
@@ -78,8 +78,8 @@ src_unpack() {
if use madwifi; then
# Add include path for madwifi-driver headers
- echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
- echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
fi
}