summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/dbhub/dbhub-0.424.ebuild')
-rw-r--r--net-p2p/dbhub/dbhub-0.424.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-p2p/dbhub/dbhub-0.424.ebuild b/net-p2p/dbhub/dbhub-0.424.ebuild
new file mode 100644
index 000000000000..83bf111398ed
--- /dev/null
+++ b/net-p2p/dbhub/dbhub-0.424.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/dbhub-0.424.ebuild,v 1.1 2007/03/13 12:27:35 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
+HOMEPAGE="http://dbhub.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc64 ~x86"
+IUSE="perl"
+
+DEPEND="perl? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/dbhub-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable perl) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc Documentation/*
+}