summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news')
-rw-r--r--net-news/snownews/ChangeLog9
-rw-r--r--net-news/snownews/snownews-1.5.12.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/net-news/snownews/ChangeLog b/net-news/snownews/ChangeLog
index b6e620524405..7e98cde22e8d 100644
--- a/net-news/snownews/ChangeLog
+++ b/net-news/snownews/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/snownews
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/ChangeLog,v 1.28 2009/03/20 10:31:07 cedk Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/ChangeLog,v 1.29 2009/09/22 19:17:49 cedk Exp $
+
+*snownews-1.5.12 (22 Sep 2009)
+
+ 22 Sep 2009; Cédric Krier <cedk@gentoo.org> +snownews-1.5.12.ebuild:
+ Version bump
*snownews-1.5.11 (20 Mar 2009)
diff --git a/net-news/snownews/snownews-1.5.12.ebuild b/net-news/snownews/snownews-1.5.12.ebuild
new file mode 100644
index 000000000000..a4c6b161bb21
--- /dev/null
+++ b/net-news/snownews/snownews-1.5.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/snownews-1.5.12.ebuild,v 1.1 2009/09/22 19:17:49 cedk Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Snownews, a text-mode RSS/RDF newsreader"
+HOMEPAGE="http://snownews.kcore.de/"
+SRC_URI="http://home.kcore.de/~kiza/software/snownews/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libxml2-2.5.6
+ >=sys-libs/ncurses-5.3
+ dev-libs/openssl"
+
+RDEPEND="${DEPEND}
+ dev-perl/XML-LibXML
+ dev-perl/XML-LibXSLT
+ dev-perl/libwww-perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s/-O2//" \
+ configure
+
+ sed -i -e 's/$(INSTALL) -s/$(INSTALL)/' \
+ Makefile
+}
+
+src_compile() {
+ local conf="--prefix=/usr"
+ ./configure ${conf} || die "configure failed"
+ emake CC="$(tc-getCC)" EXTRA_CFLAGS="${CFLAGS}" EXTRA_LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "make install failed"
+
+ dodoc AUTHOR Changelog CREDITS README README.de README.patching
+}