summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/leechcraft-aggregator/leechcraft-aggregator-0.5.0.ebuild')
-rw-r--r--net-news/leechcraft-aggregator/leechcraft-aggregator-0.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-news/leechcraft-aggregator/leechcraft-aggregator-0.5.0.ebuild b/net-news/leechcraft-aggregator/leechcraft-aggregator-0.5.0.ebuild
new file mode 100644
index 000000000000..23e3dc3c1586
--- /dev/null
+++ b/net-news/leechcraft-aggregator/leechcraft-aggregator-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/leechcraft-aggregator/leechcraft-aggregator-0.5.0.ebuild,v 1.1 2012/02/09 11:26:02 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mysql +sqlite postgres"
+
+DEPEND="~net-misc/leechcraft-core-${PV}[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="|| ( mysql sqlite postgres )"
+
+pkg_setup(){
+ if use mysql; then
+ ewarn "Support for MySQL databases is experimental and is more likely"
+ ewarn "to contain bugs or mishandle your data than other storage"
+ ewarn "backends. If you do not plan testing the MySQL storage backend"
+ ewarn "itself, consider using other backends."
+ ewarn "Anyway, it is perfectly safe to enable the mysql use flag as"
+ ewarn "long as at least one other storage is enabled since you will"
+ ewarn "be able to choose another storage backend at run time."
+ fi
+}