summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sobby')
-rw-r--r--net-misc/sobby/ChangeLog9
-rw-r--r--net-misc/sobby/files/sobby-conf-0.4.77
-rwxr-xr-xnet-misc/sobby/files/sobby-init-0.4.722
-rw-r--r--net-misc/sobby/files/sobby.xml14
-rw-r--r--net-misc/sobby/sobby-0.4.7.ebuild60
5 files changed, 111 insertions, 1 deletions
diff --git a/net-misc/sobby/ChangeLog b/net-misc/sobby/ChangeLog
index 40070428fc31..e387ffbf645b 100644
--- a/net-misc/sobby/ChangeLog
+++ b/net-misc/sobby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/sobby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/ChangeLog,v 1.23 2010/06/13 09:05:48 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/ChangeLog,v 1.24 2010/06/18 07:50:26 xarthisius Exp $
+
+*sobby-0.4.7 (18 Jun 2010)
+
+ 18 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/sobby-conf-0.4.7, +files/sobby-init-0.4.7, +sobby-0.4.7.ebuild,
+ +files/sobby.xml:
+ Version bump
13 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> metadata.xml:
Add dev-zero and myself as maintainers
diff --git a/net-misc/sobby/files/sobby-conf-0.4.7 b/net-misc/sobby/files/sobby-conf-0.4.7
new file mode 100644
index 000000000000..d6332cea2b46
--- /dev/null
+++ b/net-misc/sobby/files/sobby-conf-0.4.7
@@ -0,0 +1,7 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/files/sobby-conf-0.4.7,v 1.1 2010/06/18 07:50:25 xarthisius Exp $
+
+SOBBY_OPTS="-c /etc/sobby/sobby.xml"
+SOBBY_USER="sobby"
+SOBBY_GROUP="sobby"
diff --git a/net-misc/sobby/files/sobby-init-0.4.7 b/net-misc/sobby/files/sobby-init-0.4.7
new file mode 100755
index 000000000000..ca3ce994e062
--- /dev/null
+++ b/net-misc/sobby/files/sobby-init-0.4.7
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/files/sobby-init-0.4.7,v 1.1 2010/06/18 07:50:25 xarthisius Exp $
+
+depend() {
+ use avahi
+}
+
+start() {
+ ebegin "Starting obby dedicated server"
+ start-stop-daemon -b --quiet --start --make-pidfile \
+ --pidfile /var/run/sobby.pid --chuid ${SOBBY_USER}:${SOBBY_GROUP} \
+ --exec /usr/bin/sobby -- ${SOBBY_OPTS}
+ eend $? "Failed to start sobby"
+}
+
+stop() {
+ ebegin "Stopping obby dedicated server"
+ start-stop-daemon --stop --quiet --pidfile /var/run/sobby.pid
+ eend $? "Failed to stop sobby"
+}
diff --git a/net-misc/sobby/files/sobby.xml b/net-misc/sobby/files/sobby.xml
new file mode 100644
index 000000000000..b61a89f211e5
--- /dev/null
+++ b/net-misc/sobby/files/sobby.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<sobby_config>
+ <settings>
+ <autosave_directory>/var/lib/sobby</autosave_directory>
+ <autosave_file>autosave.obby</autosave_file>
+ <autosave_interval>0</autosave_interval>
+ <command_directory></command_directory>
+ <name>Standalone obby server</name>
+ <password>secret</password>
+ <port>6522</port>
+ <post_save_hook></post_save_hook>
+ <session></session>
+ </settings>
+</sobby_config>
diff --git a/net-misc/sobby/sobby-0.4.7.ebuild b/net-misc/sobby/sobby-0.4.7.ebuild
new file mode 100644
index 000000000000..de66110ab7cd
--- /dev/null
+++ b/net-misc/sobby/sobby-0.4.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sobby/sobby-0.4.7.ebuild,v 1.1 2010/06/18 07:50:26 xarthisius Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Standalone Obby server"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="avahi"
+
+RDEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ >=dev-cpp/libxmlpp-2.6
+ >=net-libs/net6-1.3.12
+ >=net-libs/obby-0.4.6[avahi=]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ enewgroup sobby
+ enewuser sobby -1 -1 /var/lib/sobby sobby
+}
+
+src_configure() {
+ econf $(use_enable avahi zeroconf)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ newconfd "${FILESDIR}/${PN}-conf-${PV}" sobby || die
+ newinitd "${FILESDIR}/${PN}-init-${PV}" sobby || die
+
+ insinto /etc/sobby
+ doins "${FILESDIR}/sobby.xml" || die
+
+ keepdir /var/lib/sobby || die
+
+ fperms -R 0700 /var/lib/sobby || die
+ fperms -R 0700 /etc/sobby || die
+
+ fowners sobby:sobby /var/lib/sobby || die
+ fowners -R sobby:sobby /etc/sobby || die
+}
+
+pkg_postinst() {
+ elog "To start sobby, you can use the init script:"
+ elog " /etc/init.d/sobby start"
+ elog ""
+ elog "Please check the configuration in /etc/sobby/sobby.xml"
+ elog "before you start sobby"
+}