summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rdesktop/rdesktop-1.2_beta1-r1.ebuild')
-rw-r--r--net-misc/rdesktop/rdesktop-1.2_beta1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/rdesktop/rdesktop-1.2_beta1-r1.ebuild b/net-misc/rdesktop/rdesktop-1.2_beta1-r1.ebuild
new file mode 100644
index 000000000000..a6d38379d8d6
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.2_beta1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.2_beta1-r1.ebuild,v 1.1 2002/12/29 16:37:44 bcowan Exp $
+
+IUSE="ssl"
+
+MY_P="${P/_/}"
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://rdesktop.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="x11-base/xfree
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_compile() {
+ local myconf
+
+ use ssl \
+ && myconf="--with-openssl=/usr/include/openssl" \
+ || myconf="--without-openssl"
+
+ [ "${DEBUG}" ] && myconf="${myconf} --with-debug"
+
+ sed -e "s/-O2/${CFLAGS}/g" Makefile > Makefile.tmp && mv Makefile.tmp Makefile
+ echo "CFLAGS += ${CXXFLAGS}" >> Makeconf
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sharedir=/usr/share/${PN} \
+ ${myconf}
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install
+
+ dodoc COPYING doc/HACKING doc/TODO doc/keymapping.txt
+}