summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-0.73.0.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.73.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-0.73.0.ebuild b/net-misc/ipv6calc/ipv6calc-0.73.0.ebuild
new file mode 100644
index 000000000000..824907d4cad0
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.73.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.73.0.ebuild,v 1.1 2009/08/16 19:21:44 pva Exp $
+
+inherit fixheadtails
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+DEPEND="geoip? ( >=dev-libs/geoip-1.4.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ht_fix_file configure
+}
+
+src_compile() {
+ econf $(use_enable geoip)
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog CREDITS README TODO USAGE || die
+}