summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/csync/csync-0.70.7.ebuild')
-rw-r--r--net-misc/csync/csync-0.70.7.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/csync/csync-0.70.7.ebuild b/net-misc/csync/csync-0.70.7.ebuild
new file mode 100644
index 000000000000..8ee0d8705a7a
--- /dev/null
+++ b/net-misc/csync/csync-0.70.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/csync/csync-0.70.7.ebuild,v 1.1 2013/04/29 15:53:42 kensington Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A file synchronizer especially designed for you, the normal user"
+HOMEPAGE="http://csync.org/"
+SRC_URI="http://download.owncloud.com/download/o${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv samba +sftp test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/iniparser-3.1
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh )
+"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check dev-util/cmocka )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.60.2-removebadtest.patch"
+)
+
+S="${WORKDIR}/o${P}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/ocsync:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba Libsmbclient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}/usr/etc/ocsync" "${D}/etc/"
+ rm -r "${D}/usr/etc/"
+}