summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/t-prot/t-prot-2.2.ebuild')
-rw-r--r--net-mail/t-prot/t-prot-2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mail/t-prot/t-prot-2.2.ebuild b/net-mail/t-prot/t-prot-2.2.ebuild
new file mode 100644
index 000000000000..1f99ca8d4cd9
--- /dev/null
+++ b/net-mail/t-prot/t-prot-2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/t-prot/t-prot-2.2.ebuild,v 1.1 2006/12/01 06:55:19 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="TOFU protection - display filter for RFC822 messages"
+HOMEPAGE="http://www.escape.de/users/tolot/mutt/"
+SRC_URI="http://www.escape.de/users/tolot/mutt/t-prot/downloads/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+RDEPEND="dev-lang/perl
+ dev-perl/Locale-gettext
+ dev-perl/Getopt-Mixed"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${S}"/contrib/t-prot-r1.*-mutt*.diff
+}
+
+src_install() {
+ dobin t-prot || die "dobin failed"
+ doman t-prot.1 || die "doman failed"
+ dodoc ChangeLog README TODO || die "dodoc failed"
+ docinto contrib
+ dodoc contrib/{README.examples,muttrc.t-prot,t-prot.sl*,filter_innd.pl} \
+ || die "dodoc contrib failed"
+}