summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/getmail/getmail-4.30.1.ebuild')
-rw-r--r--net-mail/getmail/getmail-4.30.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-4.30.1.ebuild b/net-mail/getmail/getmail-4.30.1.ebuild
new file mode 100644
index 000000000000..6665da7abc43
--- /dev/null
+++ b/net-mail/getmail/getmail-4.30.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.30.1.ebuild,v 1.1 2012/06/22 04:49:39 radhermit Exp $
+
+EAPI="4"
+
+PYTHON_COMPAT="python2_5 python2_6 python2_7"
+
+inherit python-distutils-ng
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+python_prepare_all() {
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+}