summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/xulrunner/xulrunner-1.9.2.13.ebuild')
-rw-r--r--net-libs/xulrunner/xulrunner-1.9.2.13.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/xulrunner/xulrunner-1.9.2.13.ebuild b/net-libs/xulrunner/xulrunner-1.9.2.13.ebuild
index 38c83e5f10ee..fff3ffbd5820 100644
--- a/net-libs/xulrunner/xulrunner-1.9.2.13.ebuild
+++ b/net-libs/xulrunner/xulrunner-1.9.2.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.9.2.13.ebuild,v 1.8 2011/01/01 19:53:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.9.2.13.ebuild,v 1.9 2011/03/14 06:54:45 nirbheek Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -20,7 +20,7 @@ SRC_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${MY_PV}/s
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
SLOT="1.9"
LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="+alsa debug +ipc libnotify system-sqlite wifi"
+IUSE="+alsa debug gnome +ipc libnotify system-sqlite wifi"
RDEPEND="
>=sys-devel/binutils-2.16.1
@@ -34,6 +34,10 @@ RDEPEND="
x11-libs/libXt
x11-libs/pixman
>=dev-libs/libevent-1.4.7
+ gnome? ( >=gnome-base/gnome-vfs-2.16.3
+ >=gnome-base/libgnomeui-2.16.1
+ >=gnome-base/gconf-2.16.0
+ >=gnome-base/libgnome-2.16.0 )
wifi? ( net-wireless/wireless-tools )
libnotify? ( >=x11-libs/libnotify-0.4 )"
@@ -118,6 +122,7 @@ src_configure() {
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"
+ mozconfig_annotate '' --enable-crypto
mozconfig_annotate '' --with-default-mozilla-five-home="${MOZLIBDIR}"
mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
mozconfig_annotate '' --enable-application=xulrunner
@@ -150,6 +155,8 @@ src_configure() {
mozconfig_annotate '' --with-system-bz2
mozconfig_annotate '' --with-system-libevent="${EPREFIX}"/usr
+ mozconfig_use_enable gnome gnomevfs
+ mozconfig_use_enable gnome gnomeui
mozconfig_use_enable ipc # +ipc, upstream default
mozconfig_use_enable libnotify
mozconfig_use_enable java javaxpcom