summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/qxmpp/qxmpp-0.3.61.ebuild')
-rw-r--r--net-libs/qxmpp/qxmpp-0.3.61.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-libs/qxmpp/qxmpp-0.3.61.ebuild b/net-libs/qxmpp/qxmpp-0.3.61.ebuild
new file mode 100644
index 000000000000..897ad59e6d05
--- /dev/null
+++ b/net-libs/qxmpp/qxmpp-0.3.61.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/qxmpp-0.3.61.ebuild,v 1.1 2012/04/22 12:24:58 maksbotan Exp $
+
+EAPI=3
+
+inherit multilib qt4-r2
+
+DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework."
+HOMEPAGE="http://code.google.com/p/qxmpp/"
+SRC_URI="https://github.com/downloads/0xd34df00d/qxmpp-dev/${P}-extras.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +extras"
+
+DEPEND="x11-libs/qt-core
+ x11-libs/qt-gui
+ media-libs/speex"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ eqmake4 "${S}"/qxmpp.pro "PREFIX=/usr" "LIBDIR=$(get_libdir)"
+}