summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/openh323/files')
-rw-r--r--net-libs/openh323/files/digest-openh323-1.15.33
-rw-r--r--net-libs/openh323/files/digest-openh323-1.15.63
-rw-r--r--net-libs/openh323/files/openh323-1.11.7-emptyMakefile2
-rw-r--r--net-libs/openh323/files/openh323-1.15.2-notrace.diff19
-rw-r--r--net-libs/openh323/files/openh323-1.15.6-gcc4.diff33
5 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/openh323/files/digest-openh323-1.15.3 b/net-libs/openh323/files/digest-openh323-1.15.3
new file mode 100644
index 000000000000..0aa701387840
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.15.3
@@ -0,0 +1,3 @@
+MD5 f9d25921281843fd2304da494b2e04e2 openh323-1.15.3.tar.gz 3754056
+RMD160 280dde066c6170219a578ce723b252757da92f4e openh323-1.15.3.tar.gz 3754056
+SHA256 2dab649046ca15b589bf48cfa6c6d2f3656b310ac482280f69a74eea397c91ef openh323-1.15.3.tar.gz 3754056
diff --git a/net-libs/openh323/files/digest-openh323-1.15.6 b/net-libs/openh323/files/digest-openh323-1.15.6
new file mode 100644
index 000000000000..c8854dc1c0b3
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.15.6
@@ -0,0 +1,3 @@
+MD5 6c49f41c4cec39172000586a26b98c48 openh323-1.15.6.tar.gz 3739001
+RMD160 1242cc978a9145d5ec206656849f4ac34fcef8af openh323-1.15.6.tar.gz 3739001
+SHA256 3c1d58d999aa45f0099bf2761f1d7cf858aa9d2039056377416a79aac1327569 openh323-1.15.6.tar.gz 3739001
diff --git a/net-libs/openh323/files/openh323-1.11.7-emptyMakefile b/net-libs/openh323/files/openh323-1.11.7-emptyMakefile
new file mode 100644
index 000000000000..d720acc09d37
--- /dev/null
+++ b/net-libs/openh323/files/openh323-1.11.7-emptyMakefile
@@ -0,0 +1,2 @@
+opt:
+ :
diff --git a/net-libs/openh323/files/openh323-1.15.2-notrace.diff b/net-libs/openh323/files/openh323-1.15.2-notrace.diff
new file mode 100644
index 000000000000..762f9f768b13
--- /dev/null
+++ b/net-libs/openh323/files/openh323-1.15.2-notrace.diff
@@ -0,0 +1,19 @@
+--- openh323/Makefile.in 2004-08-22 06:21:45.000000000 +0200
++++ openh323/Makefile.in.orig 2004-11-27 21:22:44.431975832 +0100
+@@ -328,12 +328,12 @@
+
+ install:
+ mkdir -p $(DESTDIR)$(LIBDIR)
+- rm -f $(DESTDIR)$(LIBDIR)/libh323_*_r.so*
+- $(INSTALL) -m 444 lib/*_r.so $(DESTDIR)$(LIBDIR)
+- (for fn in lib/*_r.so.* ; do \
++ rm -f $(DESTDIR)$(LIBDIR)/libh323_*_$(OH323_SUFFIX).so*
++ $(INSTALL) -m 444 lib/*_$(OH323_SUFFIX).so $(DESTDIR)$(LIBDIR)
++ (for fn in lib/*_$(OH323_SUFFIX).so.* ; do \
+ cd $(DESTDIR)$(LIBDIR) ; \
+ rm -f `basename $$fn` ; \
+- ln -s libh323_*_r.so `basename $$fn` ; \
++ ln -s libh323_*_$(OH323_SUFFIX).so `basename $$fn` ; \
+ done)
+ $(INSTALL) -m 444 lib/$(OH323_FILE) $(DESTDIR)$(LIBDIR)
+ ( cd $(DESTDIR)$(LIBDIR); rm libopenh323.so ; ln -s $(OH323_FILE) libopenh323.so)
diff --git a/net-libs/openh323/files/openh323-1.15.6-gcc4.diff b/net-libs/openh323/files/openh323-1.15.6-gcc4.diff
new file mode 100644
index 000000000000..277c250ec52b
--- /dev/null
+++ b/net-libs/openh323/files/openh323-1.15.6-gcc4.diff
@@ -0,0 +1,33 @@
+--- openh323-1.15.6/include/ixjlid.h 2004-08-22 06:21:06.000000000 +0200
++++ openh323-1.15.6-gcc4/include/ixjlid.h 2006-04-11 20:48:51.000000000 +0200
+@@ -836,7 +836,7 @@
+ };
+
+ static void SignalHandler(int sig);
+- ExceptionInfo * OpalIxJDevice::GetException();
++ ExceptionInfo * GetException();
+ int GetOSHandle() { return os_handle; }
+
+ protected:
+--- openh323-1.15.6/src/vic/p64.cxx 2003-03-14 08:25:55.000000000 +0100
++++ openh323-1.15.6-gcc4/src/vic/p64.cxx 2006-04-11 20:49:41.000000000 +0200
+@@ -1125,7 +1125,7 @@
+ * If input buffer not aligned, prime bit-buffer
+ * with 8 bits; otherwise, prime it with a 16.
+ */
+- if ((int)bp & 1) {
++ if ((long)bp & 1) {
+ bs_ = (u_short*)(bp + 1);
+ bb_ = *bp;
+ nbb_ = 8 - sbit;
+--- openh323-1.15.6/plugins/audio/Speex/speexcodec.cxx 2006-04-11 21:32:34.000000000 +0200
++++ openh323-1.15.6-gcc4/plugins/audio/Speex/speexcodec.cxx 2006-04-11 20:48:51.000000000 +0200
+@@ -112,7 +112,7 @@
+
+ static void * create_encoder(const struct PluginCodec_Definition * codec)
+ {
+- int mode = (int)(codec->userData);
++ int mode = (long)(codec->userData);
+
+ struct PluginSpeexContext * context = new PluginSpeexContext;
+ context->bits = new SpeexBits;