summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/linc')
-rw-r--r--net-libs/linc/ChangeLog6
-rw-r--r--net-libs/linc/files/digest-linc-0.1.221
-rw-r--r--net-libs/linc/linc-0.1.22.ebuild58
3 files changed, 64 insertions, 1 deletions
diff --git a/net-libs/linc/ChangeLog b/net-libs/linc/ChangeLog
index a69d344907e5..179871ddc5a4 100644
--- a/net-libs/linc/ChangeLog
+++ b/net-libs/linc/ChangeLog
@@ -1,8 +1,12 @@
# ChangeLog for net-libs/linc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.1 2002/05/22 23:27:50 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.2 2002/05/23 19:15:18 spider Exp $
+*linc-0.1.22 (23 May 2002)
+ 23 May 2002; Spider <spider@gentoo.org> linc-0.1.22.ebuild :
+ New version released
+
*linc-0.1.21-r1 (22 May 2002)
22 May 2002; Spider <spider@gentoo.org> linc-0.1.21-r1.ebuild ChangeLog:
Added linc, a library that eases the writing of services that uses
diff --git a/net-libs/linc/files/digest-linc-0.1.22 b/net-libs/linc/files/digest-linc-0.1.22
new file mode 100644
index 000000000000..3dc6bf7887c4
--- /dev/null
+++ b/net-libs/linc/files/digest-linc-0.1.22
@@ -0,0 +1 @@
+MD5 e1238441707b4650aeecd3a1ad45c406 linc-0.1.22.tar.bz2 176769
diff --git a/net-libs/linc/linc-0.1.22.ebuild b/net-libs/linc/linc-0.1.22.ebuild
new file mode 100644
index 000000000000..84ee85e25827
--- /dev/null
+++ b/net-libs/linc/linc-0.1.22.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.1.22.ebuild,v 1.1 2002/05/23 19:15:18 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library to ease the writing of networked applications"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=dev-libs/openssl-0.9.6"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+# libtoolize --copy --force
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+
+ # if this is disabled (use) ORBit2 will fail to build. Just force it on
+ myconf="${myconf} --with-openssl"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --enable-debug=yes || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* INSTALL NEWS TODO
+}
+
+
+
+
+