summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnxml/libnxml-0.16.ebuild')
-rw-r--r--net-libs/libnxml/libnxml-0.16.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libnxml/libnxml-0.16.ebuild b/net-libs/libnxml/libnxml-0.16.ebuild
new file mode 100644
index 000000000000..117fbcb88f96
--- /dev/null
+++ b/net-libs/libnxml/libnxml-0.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/libnxml-0.16.ebuild,v 1.1 2007/01/13 14:26:10 rbu Exp $
+
+DESCRIPTION="A C-library for parsing and writing XML 1.0/1.1 files or streams"
+HOMEPAGE="http://www2.autistici.org/bakunin/codes.php"
+SRC_URI="http://www2.autistici.org/bakunin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ ebegin "Creating documentation"
+ doxygen doxy.conf
+ eend 0
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ dohtml doc/html/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/test
+ doins test/*.c
+ fi
+}