summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/ChangeLog9
-rw-r--r--net-libs/ldns/files/ldns-1.6.3-r3151-fix-double-free.patch52
-rw-r--r--net-libs/ldns/files/ldns-1.6.8-swig.patch20
-rw-r--r--net-libs/ldns/ldns-1.6.11.ebuild (renamed from net-libs/ldns/ldns-1.6.8-r1.ebuild)14
4 files changed, 16 insertions, 79 deletions
diff --git a/net-libs/ldns/ChangeLog b/net-libs/ldns/ChangeLog
index 8dbe50afc2b8..61f53d8b883a 100644
--- a/net-libs/ldns/ChangeLog
+++ b/net-libs/ldns/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/ldns
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.18 2011/06/01 23:05:47 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ChangeLog,v 1.19 2011/09/30 14:56:58 matsuu Exp $
+
+*ldns-1.6.11 (30 Sep 2011)
+
+ 30 Sep 2011; MATSUU Takuto <matsuu@gentoo.org>
+ -files/ldns-1.6.3-r3151-fix-double-free.patch, -ldns-1.6.8-r1.ebuild,
+ -files/ldns-1.6.8-swig.patch, +ldns-1.6.11.ebuild:
+ Version bumped, bug #384249. Removed old versions.
*ldns-1.6.10 (01 Jun 2011)
diff --git a/net-libs/ldns/files/ldns-1.6.3-r3151-fix-double-free.patch b/net-libs/ldns/files/ldns-1.6.3-r3151-fix-double-free.patch
deleted file mode 100644
index 8dd310d430e0..000000000000
--- a/net-libs/ldns/files/ldns-1.6.3-r3151-fix-double-free.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Index: higher.c
-===================================================================
---- higher.c (revision 3150)
-+++ higher.c (revision 3151)
-@@ -198,7 +198,7 @@
- break;
- }
- }
-- strncpy(addr, word, LDNS_IP6ADDRLEN);
-+ strlcpy(addr, word, LDNS_MAX_LINELEN+1);
- } else {
- /* la al la la */
- if (ip6) {
-Index: packet.c
-===================================================================
---- packet.c (revision 3150)
-+++ packet.c (revision 3151)
-@@ -456,17 +456,12 @@
- {
- uint16_t rid = 0;
- #ifdef HAVE_SSL
-- unsigned char *rb;
-- rb = LDNS_XMALLOC(unsigned char, 2);
-- if (RAND_bytes(rb, 2) == 1) {
-- rid = ldns_read_uint16(rb);
-- }
-- LDNS_FREE(rb);
--#endif
-- if (rid == 0) {
-+ if (RAND_bytes((unsigned char*)&rid, 2) != 1) {
- rid = (uint16_t) random();
- }
--
-+#else
-+ rid = (uint16_t) random();
-+#endif
- ldns_pkt_set_id(packet, rid);
- }
-
-Index: net.c
-===================================================================
---- net.c (revision 3150)
-+++ net.c (revision 3151)
-@@ -652,6 +652,8 @@
- if (!data) {
- return NULL;
- }
-+ /* zero the structure for portability */
-+ memset(data, 0, sizeof(struct sockaddr_storage));
- if (port == 0) {
- port = LDNS_PORT;
- }
diff --git a/net-libs/ldns/files/ldns-1.6.8-swig.patch b/net-libs/ldns/files/ldns-1.6.8-swig.patch
deleted file mode 100644
index bad69831fd8a..000000000000
--- a/net-libs/ldns/files/ldns-1.6.8-swig.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: trunk/contrib/python/ldns.i
-===================================================================
---- trunk/contrib/python/ldns.i (revision 3440)
-+++ trunk/contrib/python/ldns.i (revision 3441)
-@@ -113,13 +113,13 @@
- %include <ldns/higher.h>
- %include <ldns/host2str.h>
- %include <ldns/host2wire.h>
--%include <ldns/net.h>//ruzne fce
-+%include <ldns/net.h>
- %include <ldns/packet.h>
- %include <ldns/rdata.h>
- %include <ldns/resolver.h>
- %include <ldns/rr.h>
- %include <ldns/str2host.h>
--%include <ldns/tsig.h> //potrebuje wire
-+%include <ldns/tsig.h>
- %include <ldns/update.h>
- %include <ldns/wire2host.h>
- %include <ldns/rr_functions.h>
diff --git a/net-libs/ldns/ldns-1.6.8-r1.ebuild b/net-libs/ldns/ldns-1.6.11.ebuild
index 3d14b057fa22..e91624c797fc 100644
--- a/net-libs/ldns/ldns-1.6.8-r1.ebuild
+++ b/net-libs/ldns/ldns-1.6.11.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.8-r1.ebuild,v 1.1 2011/03/03 04:46:43 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.11.ebuild,v 1.1 2011/09/30 14:56:58 matsuu Exp $
EAPI="3"
PYTHON_DEPEND="python? 2:2.4"
-inherit eutils python
+inherit python
DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
@@ -16,6 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
IUSE="doc gost python ssl static-libs vim-syntax"
+RESTRICT="test" # 1.6.9 has no test directory
+
RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7 )
gost? ( >=dev-libs/openssl-1 )"
DEPEND="${RDEPEND}
@@ -26,10 +28,6 @@ pkg_setup() {
python_set_active_version 2
}
-src_prepare() {
- epatch "${FILESDIR}/${P}-swig.patch"
-}
-
src_configure() {
econf \
$(use_enable gost) \
@@ -55,6 +53,10 @@ src_install() {
find "${ED}$(python_get_sitedir)" "(" -name "*.a" -o -name "*.la" ")" -type f -delete || die
fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
if use doc ; then
dohtml doc/html/* || die "dohtml failed"
fi